Package Details: rpcs3 0.0.9-2

Git Clone URL: https://aur.archlinux.org/rpcs3.git (read-only, click to copy)
Package Base: rpcs3
Description: Open-source Sony PlayStation 3 Emulator
Upstream URL: https://rpcs3.net/
Licenses: GPL2
Submitter: Sanpi
Maintainer: Sanpi
Last Packager: Sanpi
Votes: 26
Popularity: 0.76
First Submitted: 2017-07-25 19:54
Last Updated: 2020-03-25 17:56

Latest Comments

1 2 3 4 5 Next › Last »

Sanpi commented on 2020-04-08 16:32

@KozRoss tell me if installing the qt5-declarative package fix the problem. I’ll add its to dependencies.

KozRoss commented on 2020-04-04 02:02

This failed to build for me today, due to the following:

-- Could NOT find Qt5Qml (missing: Qt5Qml_DIR) CMake Warning at 3rdparty/qt5.cmake:3 (find_package): Found package configuration file:

/usr/lib64/cmake/Qt5/Qt5Config.cmake

but it set Qt5_FOUND to FALSE so package "Qt5" is considered to be NOT FOUND. Reason given by package:

Failed to find Qt5 component "Qml" config file at "/usr/lib64/cmake/Qt5Qml/Qt5QmlConfig.cmake"

Call Stack (most recent call first): rpcs3/CMakeLists.txt:40 (include)

-- CXX target rpcs3_emu cotired without unity build excluding ../../Utilities/JIT.cpp, Cell/PPUTranslator.cpp. -- RPCS3_GIT_VERSION: unknown -- RPCS3_GIT_BRANCH: unknown -- CXX target rpcs3 cotired without unity build. -- Configuring done CMake Error at rpcs3/CMakeLists.txt:74 (add_executable): Target "rpcs3" links to target "Qt5::Qml" but the target was not found. Perhaps a find_package() call is missing for an IMPORTED target, or an ALIAS target is missing?

CMake Error at rpcs3/CMakeLists.txt:74 (add_executable): Target "rpcs3" links to target "Qt5::Qml" but the target was not found. Perhaps a find_package() call is missing for an IMPORTED target, or an ALIAS target is missing?

CMake Error at rpcs3/rpcs3qt/CMakeLists.txt:73 (add_library): Target "rpcs3_ui" links to target "Qt5::Qml" but the target was not found. Perhaps a find_package() call is missing for an IMPORTED target, or an ALIAS target is missing?

-- Generating done CMake Generate step failed. Build files cannot be regenerated correctly.

Sanpi commented on 2020-03-25 17:57

@Anaeijon done!

Anaeijon commented on 2020-03-25 16:52

@Sanpi I had to install vulkan-devel to compile this. Maybe spirv-tools and vulkan-headers would have been sufficient (according to your comment), but I installed the whole group.

Could you please add spirv-tools and vulkan-headers to makedepends for convenience? Is there a reason not to have them in makedepends?

Sanpi commented on 2020-01-10 09:14

@Feresey I have received this message:

==> Validazione di source file con sha256sums...
    v0.0.8.tar.gz ... Verificato
    FAudio.tar.gz ... Verificato
    cereal.tar.gz ... NON RIUSCITO
    ffmpeg.tar.gz ... Verificato
    hidapi.tar.gz ... Verificato
    libpng.tar.gz ... Verificato
    libusb.tar.gz ... Verificato
    pugixml.tar.gz ... Verificato
    span.tar.gz ... Verificato
    xxhash.tar.gz ... NON RIUSCITO
    yaml-cpp.tar.gz ... Verificato
    zlib.tar.gz ... NON RIUSCITO
    glslang.tar.gz ... NON RIUSCITO
    asmjit.tar.gz ... Verificato
    llvm.tar.gz ... NON RIUSCITO
    git-version.h ... Verificato
==> ERRORE: Uno o più file non hanno superato il controllo di
validità!

It’s probably when I build the package in the same directory than the old version. It’s could be a good idea to add a version to the packages names.

Feresey commented on 2020-01-09 20:58

why "out of date"? It compiles perfectly.

Germanicus commented on 2019-10-05 18:14

Today's build (v0.0.7-8829 Alpha [2019-10-05]) fixed vulkan not showing up as a renderer option for me. The appimage can be downloaded directly from their website until this package is brought back up to date.

Sanpi commented on 2019-09-20 09:24

@maxbla I have only spirv-tools and vulkan-headers packages installed from vulkan-devel.

maxbla commented on 2019-09-19 09:46

@fazo96 using vulkan, I couldn't boot any game. Installing vulkan-devel, then recompiling (makepkg -fsi) allowed me to use vulkan. I'm not sure which packages in vulkan-devel are actually necessary, but I hope this helps someone out!

fazo96 commented on 2019-09-09 20:39

@Sanpi unfortunately I still don't have it... I am not sure what the cause is. I play games through Vulkan regularly, mostly using Steam's Proton. For some reason RPCS3 is not detecting it. The OpenGL renderer in RPCS3 works fine