Package Details: rpi-eeprom-git r436.a4c259a-1

Git Clone URL: https://aur.archlinux.org/rpi-eeprom-git.git (read-only, click to copy)
Package Base: rpi-eeprom-git
Description: Raspberry Pi4 boot EEPROM updater, latest git version
Upstream URL: http://github.com/raspberrypi/rpi-eeprom
Licenses: custom
Conflicts: rpi-eeprom
Provides: rpi-eeprom
Submitter: moonman
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 0
Popularity: 0.000000
First Submitted: 2020-05-25 00:29 (UTC)
Last Updated: 2021-12-10 22:57 (UTC)

Dependencies (3)

Required by (0)

Sources (2)

Latest Comments

moonman commented on 2021-11-21 08:12 (UTC) (edited on 2021-11-21 08:30 (UTC) by moonman)

This package is obsolete now that ALARM provides one in its own repo: rpi-eeprom https://archlinuxarm.org/forum/viewtopic.php?f=3&t=15366 Disowned

DragonX256 commented on 2021-11-21 05:01 (UTC)

PKGBUILD needs to be updated. rpi-eeprom-digest not found. Try re-installing the rpi-eeprom package

slimb commented on 2021-07-20 00:01 (UTC)

+1 to petrkutalek comment. assumption for utils satisfied by base-devel is for build-time dependencies, not for run-time. strings is required at run-time thus binutils should be included in depends

octavecurrantfer commented on 2021-07-12 00:46 (UTC) (edited on 2021-07-12 00:47 (UTC) by octavecurrantfer)

However, the package does not have to be created on the same machine on which it will be installed. For example, I create packages on one RPi, then distribute them to other nodes where base-devel is not installed, but only base. But yes, no problem, I will fix your script on my side. Thanks, though.

moonman commented on 2021-07-12 00:41 (UTC)

binutils is part of base-devel group which is required to build any aur packages. It is not required to be listed as a dep.

octavecurrantfer commented on 2021-07-10 20:56 (UTC)

rpi-eeprom-update requires strings utility which is part of binutils package. I think it should be listed as a dependency, too.

slimb commented on 2021-03-11 09:50 (UTC)

Thanks!

moonman commented on 2021-03-08 20:28 (UTC)

aarch64 official repo didn't have raspberrypi-firmware (now it does). So I guess it was made optional. Since ALARM repo has official raspberrypi-firmware now for aarch64, it's not optional anymore.

slimb commented on 2021-03-08 06:50 (UTC)

This doesn't really work without vcgencmd (provided by raspberrypi-firmware). Should it really be optional, or am I just missing something?

moonman commented on 2021-03-05 22:22 (UTC)

Fixed. Thank you

xamindar commented on 2021-02-20 07:04 (UTC)

This fails to install with error: ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> WARNING: Using existing $srcdir/ tree ==> Starting pkgver()... ==> Entering fakeroot environment... ==> Starting package()... install: cannot stat '/home/xamindar/.cache/yay/rpi-eeprom-git/src/rpi-eeprom/firmware/vl805': No such file or directory ==> ERROR: A failure occurred in package(). Aborting...