Package Details: rpm-org 4.14.2.1-1

Git Clone URL: https://aur.archlinux.org/rpm-org.git (read-only)
Package Base: rpm-org
Description: RPM Package Manager - RPM.org fork, used in major RPM distros
Upstream URL: http://www.rpm.org/
Licenses: GPL2
Conflicts: rpm, rpmextract
Provides: rpm=4.14.2.1, rpmextract=1.0-4
Submitter: Wintershade
Maintainer: codyps
Last Packager: codyps
Votes: 136
Popularity: 0.701609
First Submitted: 2009-09-20 15:51
Last Updated: 2018-10-24 16:47

Dependencies (10)

Required by (103)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

JonnyJD commented on 2015-05-18 08:19

I added a patch for lua 5.3 in an updated PKGUBILD. Please test.

JonnyJD commented on 2015-05-17 19:15

Hm, looks like Lua 5.3 broke the API or at least deprecated some of it:
http://www.lua.org/manual/5.3/manual.html#8.3

A quick fix might be to get or compile a lua 5.2 or 5.1.
I might check tomorrow if that is something I can fix easily.

rastersoft commented on 2015-05-17 19:01

I receive this message when creating the package:

libtool: link: gcc -std=gnu99 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -fPIC -DPIC -D_REENTRANT -Wall -Wpointer-arith -Wmissing-prototypes -Wstrict-prototypes -fno-strict-aliasing -fstack-protector -Wempty-body -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,-z -Wl,relro -o .libs/rpm2cpio rpm2cpio.o lib/.libs/librpm.so /built_tmp_packages/rpm-org/src/rpm-4.12.0.1/rpmio/.libs/librpmio.so -lcap -ldb rpmio/.libs/librpmio.so -lbz2 -lelf -llzma -llua -lm -lnss3 -lpopt -lz -ldl -lpthread
/built_tmp_packages/rpm-org/src/rpm-4.12.0.1/rpmio/.libs/librpmio.so: undefined reference to `luaL_optint'
/built_tmp_packages/rpm-org/src/rpm-4.12.0.1/rpmio/.libs/librpmio.so: undefined reference to `luaL_checkint'
collect2: error: ld returned 1 exit status
Makefile:968: recipe for target 'rpm2cpio' failed

Can someone help me?

JonnyJD commented on 2015-02-04 22:21

transient? I don't have problems accessing right now.

dape commented on 2015-02-03 21:23

url timeouts..

JonnyJD commented on 2014-08-28 09:19

I am also shipping the 4.12.0-rc1.
This is fairly stable. There was a previous alpha release in June and a beta release this month.

You can find previous PKGBUILDs in the log of https://github.com/JonnyJD/PKGBUILDs/tree/master/_suse/rpm-org if you want to stay stable for now.

JonnyJD commented on 2014-08-28 09:11

This installs the python 2 and 3 modules now.

roman-neuhauser commented on 2014-08-27 11:05

it would be awesome to have support for python2 *and* python3, i need to use the rpm module with both.

r08 commented on 2014-04-17 21:21

I'd like to thank JonnyJD for keeping this package up-to-date unlike laloch who has an rpm package that's old and doesn't build.

ducakar commented on 2013-08-20 08:37

@jan.hradek:
No, pkg-config is only a build-time dependency and it is in base-devel group, which everyone who builds packages should have installed. Build dependencies that are already in base or base-devel group are never included in a PKGBUILD.