Package Details: rpm-org 4.14.2.1-1

Git Clone URL: https://aur.archlinux.org/rpm-org.git (read-only)
Package Base: rpm-org
Description: RPM Package Manager - RPM.org fork, used in major RPM distros
Upstream URL: http://www.rpm.org/
Licenses: GPL2
Conflicts: rpm, rpmextract
Provides: rpm=4.14.2.1, rpmextract=1.0-4
Submitter: Wintershade
Maintainer: codyps
Last Packager: codyps
Votes: 136
Popularity: 0.693389
First Submitted: 2009-09-20 15:51
Last Updated: 2018-10-24 16:47

Dependencies (10)

Required by (103)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

jan.hradek commented on 2013-08-20 07:46

Please add pkg-config as a dependency. I had to do this to fix the following error in configure:

checking for nspr.h... no
configure: error: missing required NSPR / NSS header

jan.hradek commented on 2013-08-20 07:45

Please add pkg-config as a dependency. I had to do this to fix the following error in configure:

checking for nspr.h... no
configure: error: missing required NSPR / NSS header

JonnyJD commented on 2013-06-21 23:54

Thanks, I kind of forgot that I was also shipping the RCs here.

The reason for that are these, by the way:
- maintainer said they are quite stable (just wanted to try a RC this time)
- Nothing much depends on this actually here
- We are always on the edge anyways

pnorcks commented on 2013-06-21 22:33

4.11.1 rc2 is available.

JonnyJD commented on 2013-04-29 14:27

I added the patch and --with-cap.

I also fixed some namcap warnings.
Moved rpm from /bin to /usr/bin. There is no real reason to keep it in /bin on Arch Linux. Tell me if this makes problems, then I would add a symlink to /bin, but since this isn't used often in a shebang, this will probably be fine.

felipec commented on 2013-04-28 10:14

This is missing --with-cap, and Fedora's patch for X-CheckUnifiedSystemdir, otherwise Fedora packages can't be used.

http://pkgs.fedoraproject.org/cgit/rpm.git/plain/rpm-4.10.90-rpmlib-filesystem-check.patch?id=b1ec72fa5cda3c328da8ff964889939cd840132c

JonnyJD commented on 2013-04-04 16:53

Updated. Thanks for the notification.

Because there was some previous upstream work to support lua 5.2 I added an additional patch and changed depends to "lua" (previously lua51).
I also added libarchive, since rpmextract uses bsdtar (which is in that package).

Please report if you run into any lua problems because there are also changes in the language with lua 5.2:
http://www.lua.org/manual/5.2/manual.html#8.1

You can find the old PKGBUILD here:
https://github.com/JonnyJD/PKGBUILDs/blob/884d93ceec2202a8ba63566600930e8af7eedf21/_suse/rpm-org/PKGBUILD

pnorcks commented on 2013-04-04 05:59

Version 4.11.0.1 was released:

http://www.rpm.org/wiki/Releases/4.11.0
http://www.rpm.org/wiki/Releases/4.11.0.1

JonnyJD commented on 2013-01-28 17:22

FYI: This package is now in https://github.com/JonnyJD/PKGBUILDs

AlD commented on 2013-01-15 13:06

Updated the PKGBUILD to incorporate the required changes mentioned in comments.