Package Details: rpm-org 4.14.2.1-1

Git Clone URL: https://aur.archlinux.org/rpm-org.git (read-only)
Package Base: rpm-org
Description: RPM Package Manager - RPM.org fork, used in major RPM distros
Upstream URL: http://www.rpm.org/
Licenses: GPL2
Conflicts: rpm, rpmextract
Provides: rpm=4.14.2.1, rpmextract=1.0-4
Submitter: Wintershade
Maintainer: codyps
Last Packager: codyps
Votes: 136
Popularity: 0.714723
First Submitted: 2009-09-20 15:51
Last Updated: 2018-10-24 16:47

Dependencies (10)

Required by (103)

Sources (4)

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10

luka commented on 2010-09-06 14:56

@konrad
thank you

Anonymous comment on 2010-09-06 14:32

@luka12345:
Added building of the python bindings and updated makedepends.

luka commented on 2010-09-06 13:49

please enable python so this package can be used with yum...

http://aur.pastebin.com/VatLGK2a

http://aur.archlinux.org/packages.php?ID=22976

Anonymous comment on 2010-08-29 13:37

Well, I would say /bin is the correct location for the rpm binary...

Anonymous comment on 2010-08-29 13:32

Thanks, I tried that, got another error, and deleted the /var/lib/rpm/Packages file manually, now it seems to be working. :) Should have googled that one :P

But about the location of the executable in /bin/rpm, is there any special reason for this? I could just include it in my path, but thought I hould mention it, in case it should be in /usr/bin instead of /bin

Anonymous comment on 2010-08-29 13:12

It looks like you have an old db. Try to:
- remove /var/lib/rpm/__db.* files (make a backup before)
- rebuild your rpm db with "rpmdb --rebuilddb"

Anonymous comment on 2010-08-29 13:00

I get the following error when adding a pseudo-package to rpm to get adobe-air working:
[root@blad rpm]# /bin/rpm -ivh /root/rpmbuild/RPMS/noarch/rpm-4.7.1-1.noarch.rpm
rpmdb: Program version 4.8 doesn't match environment version 4.7
feil: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
feil: kan ikke åpne Packages-indeks ved bruk av db3 - (-30971)
feil: kan ikke åpne pakkedatabase i /var/lib/rpm
rpmdb: Program version 4.8 doesn't match environment version 4.7
feil: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
feil: kan ikke åpne pakkedatabase i /var/lib/rpm

Any idea?

Anonymous comment on 2010-08-29 12:53

The rpm executable itself neds up in /bin/rpm instead of /usr/bin. The rest of the executables end up in /usr/bin/exectable. Is this by purpose or accident? I get an error message every time i run rpm, I have to type /bin/rpm for it to work.

niqingliang2003 commented on 2010-07-15 11:19

還是這個比較靠譜