Package Details: rsibreak-git 20120611-2

Git Clone URL: https://aur.archlinux.org/rsibreak-git.git (read-only)
Package Base: rsibreak-git
Description: RSIBreak takes care of your health and regularly breaks your work to avoid repetitive strain injury (RSI)
Upstream URL: http://userbase.kde.org/RSIBreak
Licenses: GPL
Conflicts: rsibreak
Provides: rsibreak
Submitter: edio
Maintainer: edio
Last Packager: edio
Votes: 12
Popularity: 0.000000
First Submitted: 2012-06-11 11:11
Last Updated: 2015-07-06 15:10

Dependencies (5)

Required by (0)

Sources (0)

Latest Comments

1 2 Next › Last »

edio commented on 2017-05-03 08:29

@promike,
I'm no longer using this app. Would you be willing to own this package?

If yes, I will disown it right away, so you could take ownership of it.

promike commented on 2017-05-03 08:10

As a matter of fact, the makedepends list should be updated.
You cannot really compile the package without these dependencies:

makedepends=('automoc4' 'git'
'python' 'extra-cmake-modules' 'kdoctools')

edio, update your PKGBUILD as soon as you can, please!

anntzer commented on 2016-01-08 08:55

Adding extra-cmake-modules as makedepends seems to solve the issue. Also 0.12 has been released recently, so making a non-git release seems suitable.

anntzer commented on 2016-01-07 20:45

Currently fails to build:

==> GIT checkout done or server timeout
-- The C compiler identification is GNU 5.3.0
-- The CXX compiler identification is GNU 5.3.0
-- Check for working C compiler: /usr/lib/ccache/bin/cc
-- Check for working C compiler: /usr/lib/ccache/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/c++
-- Check for working CXX compiler: /usr/lib/ccache/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:6 (find_package):
Could not find a package configuration file provided by "ECM" (requested
version 1.7.0) with any of the following names:

ECMConfig.cmake
ecm-config.cmake

Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
to a directory containing one of the above files. If "ECM" provides a
separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/makepkg/rsibreak-git/src/rsibreak-build/CMakeFiles/CMakeOutput.log".

dkorzhevin commented on 2013-05-02 21:23

Works for me too. Thanks for this package, cool program!

edio commented on 2013-03-06 20:48

2raffomania
I hate to say this, but works for me.
http://sprunge.us/YEEh

You'd better ask on forum, as I'm not a qt developer and I can't diagnose the problem by myself (while I even can't reproduce it).

raffomania commented on 2013-03-06 11:38

Fails because QT_QT_INCLUDE_DIR is set to NOTFOUND.

edio commented on 2012-06-11 11:12

Use git version please
https://aur.archlinux.org/packages.php?ID=59947

edio commented on 2011-09-12 10:04

Kalinda,
I'm not available to update this right now, as my machine is not available now.

I will be able to do this in approximately 2 weeks or so.
Though, if you want, I would orphan the package so another maintainer could own the package and update it.

Kalinda commented on 2011-09-10 21:20

http://quickgit.kde.org/?p=rsibreak.git&a=summary - the URL for the GIT is here, too