Package Details: rstudio-desktop-bin 1.1.463-1

Git Clone URL: https://aur.archlinux.org/rstudio-desktop-bin.git (read-only)
Package Base: rstudio-desktop-bin
Description: An integrated development environment (IDE) for R (binary from RStudio official repository)
Upstream URL: http://www.rstudio.org/
Licenses: GPL
Conflicts: rstudio-desktop, rstudio-desktop-git, rstudio-desktop-preview-bin
Provides: rstudio-desktop=1.1.463
Submitter: Meow
Maintainer: Meow
Last Packager: Meow
Votes: 261
Popularity: 3.831756
First Submitted: 2011-06-16 16:26
Last Updated: 2018-11-28 06:39

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

leonardof commented on 2017-07-12 15:33

@coxackie, Trusted users are free to pick any package they want.

coxackie commented on 2017-07-12 07:10

The popularity of this package is huge - I am wondering why it has not moved to community yet. Does not appear to be a licence problem (AGPLv3).

hopimet commented on 2017-07-10 09:28

I modified the PKGBUILD to try to install the preview version of rstudio-1.0.147 for debian 9. It works fine and I could remove the obsolete gstreamer0.10 package.

Here is the PKGBUILD for those who want to try it:
https://pastebin.com/c5axeXZq

It works only for 64 bits systems.

hopimet commented on 2017-07-08 08:32

It seems that the preview version dedicated to debian 9 / ubuntu xenial now depends on the new libgstreamer.
[Depends: libjpeg62, libedit2, libssl1.0.0 | libssl1.0.2, libgstreamer1.0-0, libgstreamer-plugins-base1.0-0, libc6 (>= 2.7)]

The deb package is here:
https://www.rstudio.com/products/rstudio/download/preview/

Last link of the installers (for ubuntu):
https://s3.amazonaws.com/rstudio-dailybuilds/rstudio-xenial-1.0.147-amd64.deb
(only for 64 bits systems)

zertyz commented on 2017-07-07 17:19

facing issues with gstreamer-0.10 package, which seems to not provide many needed lib files anymore. Don't know where to get the required .so's.

Some of the messages:
# /usr/lib/rstudio/bin/rstudio: error while loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory
# /usr/lib/rstudio/bin/rstudio: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory
# /usr/lib/rstudio/bin/rstudio: error while loading shared libraries: libgstinterfaces-0.10.so.0: cannot open shared object file: No such file or directory
# /usr/lib/rstudio/bin/rstudio: error while loading shared libraries: libgstpbutils-0.10.so.0: cannot open shared object file: No such file or directory
# /usr/lib/rstudio/bin/rstudio: error while loading shared libraries: libgstvideo-0.10.so.0: cannot open shared object file: No such file or directory

dviktor commented on 2017-06-26 12:30

@proft
I move 'pandoc' and 'pandoc-citeproc' to the optdepends section
RStudio builds and runs without issue
If you have not pandoc installed you will have no RMarkdown support

mikkelbue commented on 2017-06-26 10:49

@proft
I simply removed 'pandoc' and 'pandoc-citeproc' from depends=() in the PKGBUILD.

RStudio still starts. Some fyunctionality may be broken, but it avoids the half-gig-haskell dependencies.

proft commented on 2017-06-26 08:30

How to disable pandoc relationship?
Last installation of rstudio requires pandoc with 544 mb dependencies :(.

dviktor commented on 2017-06-25 12:31

No, it have only symlinks to the system-wide pandoc...

leonardof commented on 2017-06-24 23:02

Why the package depends on pandoc when it ships its own pandoc and pandoc-citeproc?