Package Details: rtags 2.38-1

Git Clone URL: https://aur.archlinux.org/rtags.git (read-only, click to copy)
Package Base: rtags
Description: A client/server application that indexes C/C++ code
Upstream URL: https://github.com/Andersbakken/rtags
Keywords: c c++ client indexer rtags server
Licenses: GPL3
Conflicts: rtags-git
Submitter: jetm
Maintainer: jetm
Last Packager: jetm
Votes: 17
Popularity: 0.52
First Submitted: 2017-03-28 03:42
Last Updated: 2020-01-20 15:46

Pinned Comments

jetm commented on 2020-12-18 19:19

rtags v2.40 is not building on Arch Linux. Issue: https://github.com/Andersbakken/rtags/issues/1401

Latest Comments

1 2 3 Next › Last »

carlosal1015 commented on 2021-03-04 21:21

Hi, when I do yay -G rtags && cd rtags && makepkg -src its fails:

[ 84%] Building CXX object src/CMakeFiles/rtags.dir/TokensJob.cpp.o
[ 86%] Linking CXX static library librtags.a
[ 86%] Built target rtags
make: *** [Makefile:160: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...

and this is the Makefile:

158 all: cmake_check_build_system
159         $(CMAKE_COMMAND) -E cmake_progress_start /tmp/rtags/src/rtags/CMakeFiles /tmp/rtags/src/rtags//CMakeFiles/progress.marks
160         $(MAKE) $(MAKESILENT) -f CMakeFiles/Makefile2 all
161         $(CMAKE_COMMAND) -E cmake_progress_start /tmp/rtags/src/rtags/CMakeFiles 0

Some help? It could be the twice // on line 159?

jetm commented on 2020-12-18 19:19

rtags v2.40 is not building on Arch Linux. Issue: https://github.com/Andersbakken/rtags/issues/1401

Thaodan commented on 2020-11-07 14:17

Do you intend to not install the elisp files? In a clean-chroot they are not installed as emacs isn't installed.

jetm commented on 2019-05-30 14:47

@Thaoda: Thank you for pointed out that commit. I have removed those dependencies.

Thaodan commented on 2019-05-30 13:07

Can you please remove lua and selene? its no longer used. https://github.com/Andersbakken/rtags/commit/8944390593804e93c006c2964b667556c9b902a1

jetm commented on 2019-04-13 15:01

@gdkags: The last version is 2.31 and I don't see inside any cppuinit dependency. The package is working fine for me.

gdkags commented on 2019-04-12 14:07

2.21 has a new build dependency to 'cppunit', cmake checks for it and fails the build. After installing it from [extra], everything works as expected.

jetm commented on 2019-01-10 17:37

@gogoprog: thank you. The package has been updated.

gogoprog commented on 2019-01-10 17:24

The v2.21 tag is back

jetm commented on 2018-10-14 11:43

@maramon: restored to v2.20. Thank you.