Package Details: rtl8188eu-git 1.0.c5113ff-2

Git Clone URL: https://aur.archlinux.org/rtl8188eu-git.git (read-only)
Package Base: rtl8188eu-git
Description: Standalone RTL8188EU driver
Upstream URL: https://github.com/lwfinger/rtl8188eu
Licenses: GPL2
Conflicts: 8188eu, rtl8188eu
Provides: 8188eu, rtl8188eu
Submitter: mugifly
Maintainer: monotykamary
Last Packager: monotykamary
Votes: 1
Popularity: 0.420016
First Submitted: 2015-12-06 16:15
Last Updated: 2017-08-23 09:08

Dependencies (6)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

dreieck commented on 2018-09-05 21:52

You should not rely on _extramodules=extramodules-4.12-ARCH. This assumes that the user has the standard Arch Linux kernel installed. But he can choose to have another kernel.

Please make it flexible with regard to installed kernel.

dreieck commented on 2018-09-05 21:44

You should not clone into $pkgbase-$pkgver. Instead, just into $pkgbase. $pkgver will be changed later due to $pkgver().

mikecr commented on 2017-08-23 11:50

Ah sorry, my mistake! Yaourt was defaulting to installing both without prompting

monotykamary commented on 2017-08-23 09:19

@mikecr

That's a consistency issue I probably left from the community package bbswitch, which I have fixed.

As for the two packages thing, that's because it is a split package. You make either or both packages and install only one. Otherwise you would have both a built and dkms version of the module for extramodules-4.12-ARCH, which creates package confusion as to which is being used. It is why you don't have both bbswitch and bbswitch-dkms installed at the same time.

mikecr commented on 2017-08-23 09:04

Also on line 50 of the PKGBUILD the closing quotation mark is too early and on line 66 the first part isn't enclosed in quotation marks.

mikecr commented on 2017-08-23 06:57

This PKGBUILD creates two packages - rtl8188eu-dkms-git & rtl8188eu-git - which conflict with each other, installation is not possible.

monotykamary commented on 2017-08-12 16:58

@charlesmilette

That is because without dkms, the pkgbase package rtl8188eu-git refers to extramodules-4.12-ARCH so it defaults to that kernel. If no default is given, the package can fail to build in a situations like on a kernel that has been updated, but not restarted. The community pkgbase bbswitch uses the same dependency logic.

I don't know many people who remove the stock kernel, even if they already have LTS for fallback. If you want to just install it for just linux-zen, simply just edit the PKGBUILD, remove the makedepends and change `_extramodules` to reflect linux-zen in /usr/lib/modules/${_extramodules} (which I assume is extramodules-4.12-zen).

sylveon commented on 2017-08-12 16:34

I can't install this with the linux-zen kernel without pulling the complete linux kernel

monotykamary commented on 2017-08-03 10:49

I've fixed up the package, just because, and it should work in theory. I'm not too confident about module loading; but the package itself is referenced from community/bbswitch(-dkms), 8818eu-dkms, and 8192cu-dkms packages.

If you have any problems and any solutions to those problems, feel free to post it here.

baratharon commented on 2016-12-29 09:17

/usr/lib/firmware/rtlwifi/rtl8188eufw.bin is owned by linux-firmware