Package Details: rtl8723bu-git-dkms 237-1

Git Clone URL: https://aur.archlinux.org/rtl8723bu-git-dkms.git (read-only)
Package Base: rtl8723bu-git-dkms
Description: Driver for RTL8723BU DKMS version
Upstream URL: https://github.com/lwfinger/rtl8723bu
Keywords: 8723bu rtl8723bu
Licenses: GPL
Conflicts: rtl8723bu-git
Provides: rtl8723bu
Submitter: dini
Maintainer: dini
Last Packager: dini
Votes: 4
Popularity: 0.084677
First Submitted: 2017-08-18 06:53
Last Updated: 2019-06-02 16:36

Dependencies (1)

Required by (0)

Sources (3)

Pinned Comments

dini commented on 2018-12-26 00:38

If a build error occurs: Downgrading both elfutils and libelf to 0.174-1 (+ adding them to IgnorePkg) and then upgrading linux, linux-headers, etc. worked for me. After rebooting, the driver compiled just fine.

Latest Comments

dini commented on 2018-12-26 00:38

If a build error occurs: Downgrading both elfutils and libelf to 0.174-1 (+ adding them to IgnorePkg) and then upgrading linux, linux-headers, etc. worked for me. After rebooting, the driver compiled just fine.

dini commented on 2017-09-16 18:37

thx

dimich commented on 2017-09-16 16:43

Unable to build driver for kernel diffenent than currently loaded. Patch:

diff --git a/dkms.conf b/dkms.conf
index 14c33b0..884c99c 100644
--- a/dkms.conf
+++ b/dkms.conf
@@ -2,7 +2,7 @@

PACKAGE_VERSION="@PKGVER@"
PACKAGE_NAME="@_PKGBASE@"
-MAKE[0]="CONFIG_RTL8723BU=m make M=${dkms_tree}/${PACKAGE_NAME}/${PACKAGE_VERSION}/build modules"
+MAKE[0]="CONFIG_RTL8723BU=m make M=${dkms_tree}/${PACKAGE_NAME}/${PACKAGE_VERSION}/build KVER=$kernelver modules"
AUTOINSTALL=yes
BUILT_MODULE_NAME[0]="@_PKGBASE@"
DEST_MODULE_LOCATION[0]="/kernel/drivers/net/wireless"