Package Details: rtl8814au-dkms-git 4.3.21.r34.ga0c4479-2

Git Clone URL: https://aur.archlinux.org/rtl8814au-dkms-git.git (read-only)
Package Base: rtl8814au-dkms-git
Description: RTL8814AU and RTL8813AU chipset driver with firmware v4.3.21
Upstream URL: https://github.com/zebulon2/rtl8814au
Licenses: GPL2
Conflicts: rtl8814au
Submitter: zebulon
Maintainer: zebulon
Last Packager: erkexzcx
Votes: 16
Popularity: 0.030177
First Submitted: 2017-09-18 20:21
Last Updated: 2018-08-19 22:11

Dependencies (3)

Required by (0)

Sources (3)

Pinned Comments

zebulon commented on 2019-10-01 06:19

To all having an issue with this driver: please try https://aur.archlinux.org/packages/rtl88xxau-aircrack-dkms-git alternatively.

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10

bsdfirst commented on 2017-07-26 06:04

Hi all, I'm doing to disown this package as I'm not actually using the device anymore and I'm doing a poor job of keeping it up to date. Hopefully somebody who uses the device can pick this up!

a_manthey commented on 2017-06-22 10:15

its working on Kernel 4.11.6-1-Arch, thanks

bsdfirst commented on 2017-06-22 01:20

Ah. Yes. Oops. Apologies.

ohmyarch commented on 2017-06-21 01:29

==> Building and installing package
==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.

==> ERROR: An unknown error has occurred. Exiting...
==> ERROR: Makepkg was unable to build edimax_ac1750_8814au-dkms.

bsdfirst commented on 2017-06-21 00:24

Thanks a_manthey, the box I have this running on doesn't see a lot of use nowadays so I haven't patched it recently. I've added the patch you provided upstream (though I confess to have not tested this on a kernel greater or less than 4.11 - i.e. I haven't tested it at all).

a_manthey commented on 2017-06-08 20:49

On kernel 4.11 compilation exits with errors (implicit declaration of function „allow_signal“ etc.). From edimax-support i got this solution:

You're running kernel v4.11 which has the Signal related functions moved to a different file.  You need to do the following in order to make it works.
open a text editor, like nano, vi, etc.
open the file include/osdep_service_linux.h from rtl8814AU/ folder
add the following lines after this line (#48) #include <linux/sched.h>
#if (LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0))
#include <linux/sched/signal.h>
#endif
save the file
try to recompile the driver again