Package Details: rts_bpp-dkms-git 10-1

Git Clone URL: https://aur.archlinux.org/rts_bpp-dkms-git.git (read-only, click to copy)
Package Base: rts_bpp-dkms-git
Description: A kernel module for Realtek Card Reader RTL8402/8411/8411B Device
Upstream URL: https://github.com/M0Rf30/rts_bpp
Keywords: 10EC:5286 10EC:5287 10EC:5289 Barossa RTL8402 RTL8411 RTL8411B
Licenses: GPL
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 3
Popularity: 0.001165
First Submitted: 2016-08-05 13:36
Last Updated: 2020-01-26 11:29

Latest Comments

1 2 Next › Last »

eudes commented on 2020-07-28 00:41

Works in Manjaro, kernel 4.19 LTS, with Realtek RT525A. Thanks!

PythonNut commented on 2020-05-05 01:14

I implemented some fixes for Linux 5.6 at https://github.com/PythonNut/rts_bpp

KacperA commented on 2020-02-23 11:44

In PKGBUILD

pkgver() {
    cd ${_pkgname}
    echo $(git rev-list --count master)
}

echo returns 9 instead of 10 and it's cloning back version 9 which causing infinity 9->10 update. @robertfoster check this out please.

KacperA commented on 2020-02-23 11:31

It's installing version 9 every time

(1/4) Reloading device manager configuration...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Install DKMS modules
==> dkms install rts_bpp/9 -k 5.5.5-1-ck-skylake
(4/4) Cleaning pacman cache with paccache …
==> no candidate packages found for pruning

arteme commented on 2020-01-21 08:16

Thank you for picking up my dkms.conf suggestion, but we now have a different problem. git+https://github.com/Ri0n/rts_bpp.git doesn't have "define.h", while git+https://github.com/M0Rf30/rts_bpp.git does. Ri0n's Makefile is made to run "make" and "make install" in the module source dir, which is not what dkms does. Dkms runs something like "make -j8 KERNELRELEASE=5.4.13-arch1-1 -C /usr/lib/modules/5.4.13-arch1-1/build M=/var/lib/dkms/rts_bpp/10/build", (i.e. using kenel's Makefile, not the modules) that's why the default step of copying "define.release" to "define.h" never takes place.

You have multiple options: 1) copy the file in PKGBUILD's pakage() function; 2) add an executable script that does "test -f define.h || cp define.release define.h" and put it as "PRE_BUILD=my_copy_script.sh" in the dkms.conf file (putting the shell command there doesn't work, it needs to be an executablescript); 3) something else entirely...

arteme commented on 2019-12-30 13:18

To fix this, replace dkms.conf with the one from here: https://gist.github.com/arteme/74af02be36594b0163622c338ac9686a

arteme commented on 2019-12-30 12:48

Indeed, installation fails, but the issue is that the DKMS hook uses the wrong kernel version. While updating the system from kernel 5.3.7 to 5.4.6 (still running 5.3.7 kernel) I get the following:

==> dkms install rts_bpp/9 -k 5.4.6-arch3-1 Error! Bad return status for module build on kernel: 5.4.6-arch3-1 (x86_64) Consult /var/lib/dkms/rts_bpp/9/build/make.log for more information.

The latter file reads:

DKMS make.log for rts_bpp-9 for kernel 5.4.6-arch3-1 (x86_64) Mon 30 Dec 2019 02:34:26 PM EET Makefile:47: warning: overriding recipe for target 'clean' Makefile:41: warning: ignoring old recipe for target 'clean' make -C /lib/modules/5.3.7-arch1-2-ARCH/build M=/var/lib/dkms/rts_bpp/9/build modules make[1]: /lib/modules/5.3.7-arch1-2-ARCH/build: No such file or directory. Stop. make: [Makefile:39: default] Error 2

thePanz commented on 2019-12-23 09:54

With the latest kernel 5.4.6 the installation fails. See: https://bbs.archlinux.org/viewtopic.php?pid=1879065#p1879065

PythonNut commented on 2019-08-06 06:09

I implemented some fixes for Linux 5.2 at https://github.com/PythonNut/rts_bpp

archibald869 commented on 2018-12-23 10:32

Works also for RTS5249. Many thanks!