Package Details: rubick-bin 4.2.2-2

Git Clone URL: https://aur.archlinux.org/rubick-bin.git (read-only, click to copy)
Package Base: rubick-bin
Description: Electron based open source toolbox, free integration of rich plug-ins. 基于 electron 的开源工具箱,自由集成丰富插件。
Upstream URL: https://rubickcenter.github.io/rubick/
Keywords: cross-platform desktop-app electron javascript macos nodejs toolkit vuejs windows
Licenses: MIT
Conflicts: rubick
Provides: rubick
Submitter: zhuangzhuang
Maintainer: zxp19821005
Last Packager: zxp19821005
Votes: 2
Popularity: 0.018511
First Submitted: 2022-08-30 08:57 (UTC)
Last Updated: 2024-03-11 09:37 (UTC)

Dependencies (1)

Required by (0)

Sources (3)

Latest Comments

zxp19821005 commented on 2023-09-26 01:46 (UTC)

@st0ne 感谢反馈!上游作者原本是将文件安装到/opt/rubick2,后来又改变安装目录为/opt/rubick,我只是更新了版本号,没有自己编译。不好意思。已修复!

st0ne commented on 2023-09-26 01:20 (UTC)

编译失败~

node:internal/fs/utils:350
    throw err;
    ^

Error: ENOENT: no such file or directory, open '/home/stone/.cache/yay/rubick-bin/src/opt/rubick2/resources/app.asar'
    at Object.openSync (node:fs:603:3)
    at module.exports.readArchiveHeaderSync (/usr/lib/node_modules/@electron/asar/lib/disk.js:58:17)
    at module.exports.readFilesystemSync (/usr/lib/node_modules/@electron/asar/lib/disk.js:84:25)
    at module.exports.extractAll (/usr/lib/node_modules/@electron/asar/lib/asar.js:174:27)
    at Command.<anonymous> (/usr/lib/node_modules/@electron/asar/bin/asar.js:72:10)
    at Command.listener [as _actionHandler] (/usr/lib/node_modules/@electron/asar/node_modules/commander/index.js:413:31)
    at Command._parseCommand (/usr/lib/node_modules/@electron/asar/node_modules/commander/index.js:914:14)
    at Command._dispatchSubcommand (/usr/lib/node_modules/@electron/asar/node_modules/commander/index.js:865:18)
    at Command._parseCommand (/usr/lib/node_modules/@electron/asar/node_modules/commander/index.js:882:12)
    at Command.parse (/usr/lib/node_modules/@electron/asar/node_modules/commander/index.js:717:10) {
  errno: -2,
  syscall: 'open',
  code: 'ENOENT',
  path: '/home/stone/.cache/yay/rubick-bin/src/opt/rubick2/resources/app.asar'
}

Node.js v18.18.0
==> 错误: 在 build() 中发生一个错误。    正在放弃...
 -> 生成时出错: rubick-bin-exit status 4
 -> 无法安装以下软件包, 需要手动介入处理:
rubick-bin - exit status 4

MarsSeed commented on 2023-07-23 12:11 (UTC)

Also, you might want to consider adopting the orphan rubick and update it as well.

MarsSeed commented on 2023-07-23 12:10 (UTC)

Please use a newer, maintained Electron version.

The definition in package.json says "electron": "^13.0.0", meaning Election 13 or higher.