Package Details: ruby-adsf-live 1.4.6-1

Git Clone URL: (read-only, click to copy)
Package Base: ruby-adsf-live
Description: Live reload support for adsf
Upstream URL:
Licenses: MIT
Submitter: grawlinson
Maintainer: grawlinson
Last Packager: grawlinson
Votes: 0
Popularity: 0.000000
First Submitted: 2021-07-30 07:05 (UTC)
Last Updated: 2021-07-30 07:05 (UTC)

Latest Comments

grawlinson commented on 2022-06-11 04:38 (UTC)

A better solution would be for em1 to provide em and conflict with em.

MarsSeed commented on 2022-06-07 17:04 (UTC)

Yes, except for the off-chance that someone has ruby-eventmachine-1.0 installed but not ruby-eventmachine.

grawlinson commented on 2022-05-31 05:03 (UTC)

That isn’t an actual issue because ruby-eventmachine is in the community repository.

MarsSeed commented on 2022-05-31 04:01 (UTC) (edited on 2022-05-31 05:01 (UTC) by MarsSeed)


Please declare depends (from gemspec): eventmachine ~> 1.2. Or in PKGBUILD parlance:

depends=('ruby-eventmachine>=1.2' 'ruby-eventmachine<2')

This is needed because I've created the ruby-eventmachine-1.0 package which provides ruby-eventmachine= Without the version constraint, ruby-asdf-live might accept my legacy package as dependency if that is installed, but that will not satisfy the actual requirement defined by the gemspec.