Package Details: ruby-build 20160602-1

Git Clone URL: https://aur.archlinux.org/ruby-build.git (read-only)
Package Base: ruby-build
Description: Compile and install Ruby
Upstream URL: ruby-build-v20160602.tar.gz::https://github.com/rbenv/ruby-build
Licenses: MIT
Submitter: None
Maintainer: peterhoeg (saghm)
Last Packager: saghm
Votes: 60
Popularity: 0.864316
First Submitted: 2011-12-26 13:37
Last Updated: 2016-07-22 18:20

Dependencies (2)

Required by (2)

Sources (1)

Latest Comments

saghm commented on 2016-07-22 18:17

Okay, thanks! Sorry for bothering you about that

peterhoeg commented on 2016-07-22 03:07

@saghm, you don't have to ask - just go ahead.

saghm commented on 2016-07-22 00:56

Is it all right if I push an update for 20160602?

saghm commented on 2016-07-21 05:25

Yep, I do! Thanks so much!

peterhoeg commented on 2016-07-21 05:17

@saghm - do you have access now?

saghm commented on 2016-07-21 03:28

Sorry for the late response, I hadn't checked the comments for this package before, but I'd be willing to take over! I haven't maintained a package before, but I've been using Arch for over two years as my main OS (and have had `ruby-build` installed almost that long), and I have built some packages with ABS and written a few PKGBUILD's just to get a feel for the system.

peterhoeg commented on 2016-05-03 14:01

I'm in the process of moving off Arch Linux. Is anybody interested in taking over this package?

peterhoeg commented on 2016-03-22 06:24

Thanks @wenLiangcan. I had the old archive cached, now it's working properly. Apologies to all for the frequent rebuilds.

wenLiangcan commented on 2016-03-22 04:43

Source URL starts with https://github.com/rbenv/ruby-build/archive rather then https://github.com/rbenv/ruby-build/tarball

And the value of sha1sums is e30bab64216dafdbf709f5e64e64d84e023f9f9d

peterhoeg commented on 2016-03-22 01:22

thanks @mark.sagikazar

mark.sagikazar commented on 2016-03-21 15:43

Upstream URL has been changed: https://github.com/rbenv/ruby-build

peterhoeg commented on 2015-11-25 01:53

Thanks to @peterhu for spotting the changed sha1sum. I have verified that the packages built before and after the sha1sum change are identical.

peterhoeg commented on 2015-09-08 03:28

I have agreed with vdemeester that I will take over this package - updates will follow shortly.

warmwaffles commented on 2015-08-31 16:48

This is out of date needs to be bumped to https://github.com/sstephenson/ruby-build/releases/tag/v20150818

cpence commented on 2015-04-27 14:18

Thanks!

vdemeester commented on 2015-04-26 10:07

Took a little time to update, but it's done

cpence commented on 2015-04-20 16:00

ruby-build 20150413 released w/ Ruby 2.2.2, flagging out of date.

timonv commented on 2015-03-10 11:14

Needs update for 2.2.1 :-)

jferris commented on 2014-11-14 15:56

Updated again for Ruby 2.1.5: https://gist.github.com/jferris/7a5ca8f0f3473e3cd928

Release notes: https://www.ruby-lang.org/en/news/2014/11/13/ruby-2-1-5-is-released/

vdemeester commented on 2014-10-30 16:03

Thx :-)

jferris commented on 2014-10-30 14:52

Updated package build: https://gist.github.com/jferris/7a5ca8f0f3473e3cd928 (supports Ruby 2.1.4)

logankoester commented on 2014-05-17 20:04

Please update to git tag v20140517 or later. Thanks!

vdemeester commented on 2013-07-04 07:35

Update to last git tag (20130628)

vdemeester commented on 2013-05-12 09:44

Updated to last git tag (20130501)

vdemeester commented on 2013-04-13 07:36

Updated to the last git tag (20130408)

vdemeester commented on 2013-03-28 11:09

Updated to the last git tag (20130227).

joschi commented on 2012-02-25 16:29

Updated PKGBUILD: https://gist.github.com/ce30170bde3b99da8dfd