Package Details: ruby-chef 12.11.18-1

Git Clone URL: (read-only)
Package Base: ruby-chef
Description: A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure.
Upstream URL:
Licenses: Apache-2.0
Submitter: masterkorp
Maintainer: Loen
Last Packager: Loen
Votes: 6
Popularity: 0.000000
First Submitted: 2012-04-23 10:03
Last Updated: 2016-06-25 09:31

Latest Comments

Loen commented on 2016-06-25 09:23

I adopted the package and now it works fine

anatolik commented on 2014-07-18 14:26

D'oh, sorry about it. ruby-rest-client-1.6 just added to AUR.

BTW there is a binary repository for ruby gems. It contains many popular gems including 'ruby-chef'. Check this out

jswagner commented on 2014-07-18 07:00

"ruby-rest-client-1.6" no longer exists in the AUR? "ruby-rest-client" does, however.

flaccid commented on 2013-12-19 02:27

masterkorp commented on 2013-12-19 02:22


Thanks for the heads up.

piglovesyou commented on 2013-11-30 09:59

Looks like we want pry.

/usr/lib/ruby/2.0.0/rubygems/dependency.rb:296:in `to_specs': Could not find 'pry' (~> 0.9) among 50 total gem(s) (Gem::LoadError)
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1196:in `block in activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `each'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1167:in `activate'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem'
from /usr/bin/chef-solo:22:in `<main>'

flaccid commented on 2013-11-21 12:02

This package doesn't meet so feel free to let me know on any issues I can address.

flaccid commented on 2013-11-21 12:01

This package doesn't meet so feel free to let me know on any issues I can address.

androo commented on 2013-11-21 11:49

Please update pkgbuild to use ruby-mixlib-shellout package, now it's okay.

sakaru commented on 2013-11-21 11:41

Is this package going to be updated to 11.8 or are users supposed to move to flaccid's 'chef' package?

flaccid commented on 2013-11-13 07:43

Up to 11.8.0 now so I have created

flaccid commented on 2013-09-19 02:39

Not sure why this if flagged out of date. 11.6.0 is the latest,

ethome commented on 2013-08-24 21:49


Line 215 of /usr/lib/ruby/gems/2.0.0/gems/chef-11.6.0/lib/chef/platform/provider_mapping.rb should be changed as follows:

- :service => Chef::Provider::Service::Arch,
+ :service => Chef::Provider::Service::Systemd,

since ::Arch is about initscripts, and initscripts are gone...


roheim commented on 2013-07-31 19:40

11.0.8 is out.

anshumanb commented on 2013-05-01 07:22

The latest gem (and 11.4.0) doesn't work with Ruby 2.0 and won't work till is resolved and released.

$ chef-client -h
/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file -- rubygems/format (LoadError)
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/lib/ruby/gems/2.0.0/gems/chef-11.4.0/lib/chef/provider/package/rubygems.rb:34:in `<top (required)>'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/lib/ruby/gems/2.0.0/gems/chef-11.4.0/lib/chef/providers.rb:60:in `<top (required)>'

masterkorp commented on 2013-04-16 19:46

@jorgermp That's not the way to fix it !

You need to rebuild all your ruby-* packages because the gemdir has change due to the ruby2.0 upgrade.

Anonymous comment on 2013-04-16 09:29

Finally works uninstall net-ssh-multi-1.2.0 with

gem uninstall -v 1.2.0 net-ssh-multi

after install chef with gem

gem install chef

Anonymous comment on 2013-04-15 11:29

knife command don't work:

$ knife
/usr/lib/ruby/2.0.0/rubygems/dependency.rb:296:in `to_specs': Could not find 'net-ssh-multi' (~> 1.1.0) - did find: [net-ssh-multi-1.2.0] (Gem::LoadError)
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1196:in `block in activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `each'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1185:in `activate_dependencies'
from /usr/lib/ruby/2.0.0/rubygems/specification.rb:1167:in `activate'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_gem.rb:48:in `gem'
from /usr/bin/knife:22:in `<main>'

masterkorp commented on 2012-09-25 08:29

@ukreator Comment if the problem persists

Anonymous comment on 2012-09-24 10:31

knife doesn't work for me. Complains on one of the libs:

/usr/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find mixlib-authentication (>= 1.3.0)

jhf2442 commented on 2012-09-10 20:09

@masterkorp : thanks, works now. Strange enough... ruby-net-ssh-2.2 is in the dependency list and should've been installed. But explicitely installing resolves the issue

masterkorp commented on 2012-09-01 20:54

@jh2442 Hello, try install ruby-net-ssh-2.2 from aur Sometimes you can get that error.

jhf2442 commented on 2012-09-01 15:30

Getting : /usr/lib/ruby/1.9.1/rubygems/dependency.rb:247:in `to_specs': Could not find net-ssh (~> 2.2.2) amongst [bigdecimal-1.1.0, bunny-0.7.9, chef-10.12.0, erubis-2.7.0, highline-1.6.11, io-console-0.3, ipaddress-0.8.0, json-1.5.4, mime-types-1.19, minitest-2.5.1, mixlib-authentication-1.1.4, mixlib-cli-1.2.2, mixlib-config-1.1.2, mixlib-log-1.3.0, mixlib-shellout-1.0.0, moneta-0.6.0, net-ssh-2.5.2, net-ssh-gateway-1.1.0, net-ssh-multi-1.1, ohai-0.6.12, polyglot-0.3.3, rake-, rdoc-3.9.4, rest-client-1.6.7, systemu-2.5.0, treetop-1.4.10, uuidtools-2.1.2, yajl-ruby-1.1.0] (Gem::LoadError)
when running knife after fresh install today. Strange thing is that net-ssh-2.5.2 is reported as being available

masterkorp commented on 2012-06-04 06:46

@Ogier Thanks, done

Anonymous comment on 2012-06-04 05:04

ruby-json-1.5 is shipped by ruby-1.9.3_p194. It shouldn't be a dependency any more.

masterkorp commented on 2012-04-26 05:51

@Scullder Thanks, i must forgot that.

hcartiaux commented on 2012-04-25 23:46

Please add --no-user-install to the gem install command so the gem will not be installed in the user home directory.
The default now is --user-install (in /etc/gemrc)