Package Details: ruby-coderay 1.1.2-2

Git Clone URL: https://aur.archlinux.org/ruby-coderay.git (read-only)
Package Base: ruby-coderay
Description: Fast syntax highlighting for selected languages.
Upstream URL: http://coderay.rubychan.de
Licenses: MIT
Submitter: tdy
Maintainer: supermario
Last Packager: supermario
Votes: 23
Popularity: 0.055134
First Submitted: 2010-01-19 20:13
Last Updated: 2018-03-29 00:35

Latest Comments

albinou commented on 2018-03-27 06:05

Hi! This package requires an additional dependency: ruby-rdoc

If not installed, I get the following error:

==> Starting package()...
Successfully installed coderay-1.1.2
ERROR:  While executing gem ... (Gem::DocumentError)
    RDoc is not installed: cannot load such file -- rdoc/rdoc
==> ERROR: A failure occurred in package().
    Aborting...
==> ERROR: Makepkg was unable to build ruby-coderay.

Cheers!

anatolik commented on 2014-04-10 21:55

yaourt installs this package fine for me, so it is not a problem of the package.

I believe it is a standard problem with mixing RVM and system environments.

Nowaker commented on 2014-04-10 21:01

ERROR: While executing gem ... (Errno::ENOENT)
No such file or directory @ dir_s_mkdir - /tmp/yaourt-tmp-nowaker/aur-ruby-coderay/pkg/ruby-coderay/usr/bin
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build ruby-coderay.

fnord0 commented on 2012-07-25 11:37

newer version is available = v1.0.7
I created a PKGBUILD for ruby-coderay v1.0.7 that works great for me @ https://gist.github.com/3175659