Package Details: ruby-compass 1.0.3-3

Git Clone URL: https://aur.archlinux.org/ruby-compass.git (read-only)
Package Base: ruby-compass
Description: A Real Stylesheet Framework
Upstream URL: http://compass-style.org
Licenses: MIT
Submitter: shaleny
Maintainer: mtorromeo
Last Packager: mtorromeo
Votes: 71
Popularity: 2.193774
First Submitted: 2011-02-14 16:24
Last Updated: 2016-01-04 09:15

Dependencies (3)

Required by (5)

Sources (4)

Latest Comments

mtorromeo commented on 2016-01-07 10:34

@zebulon: you have to rebuild bundler

zebulon commented on 2016-01-07 08:06

Despite I have ruby-bundler installed, I get this error during package():

/usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'bundler' (>= 0) among 12 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/home/eric/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information
from /usr/lib/ruby/2.3.0/rubygems/dependency.rb:328:in `to_spec'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:65:in `gem'
from /usr/bin/bundle:22:in `<main>'

egore911 commented on 2015-10-13 11:17

Even after the update (https://aur.archlinux.org/cgit/aur.git/commit/?h=ruby-compass&id=6515cbf599a3f14fbc335698dad35064f04c7cd6) which bumps dependencies, the package still lacks breakpoint and susy as dependencies.

egore911 commented on 2015-09-18 08:53

I'm constantly getting:

LoadError on line ["179"] of /usr/lib/ruby/gems/2.2.0/gems/compass-1.0.3/vendor/bundle/ruby/2.2.0/gems/compass-core-1.0.3/lib/compass/configuration/data.rb: cannot load such file -- breakpoint

It seems to be by a broken(?) sass dependency as mentioned here: http://stackoverflow.com/questions/18373644/trouble-running-compass-on-osx-loaderror-on-line-51

I fixed it by patching Gemfile and calling "bundler install" once:

diff --git a/Gemfile b/Gemfile
index 697711e..f18d7b5 100644
--- a/Gemfile
+++ b/Gemfile
@@ -4,3 +4,5 @@ gem 'compass-core', "~> 1.0.2"
gem 'compass-import-once', "~> 1.0.5"
gem 'rb-fsevent', ">= 0.9.3"
gem 'rb-inotify', ">= 0.9"
+gem 'breakpoint', ">= 2.5.0"
+gem 'susy', ">= 2.2.6"
diff --git a/Gemfile.lock b/Gemfile.lock
index 60af975..66562d1 100644
--- a/Gemfile.lock
+++ b/Gemfile.lock
@@ -1,6 +1,9 @@
GEM
remote: https://rubygems.org/
specs:
+ breakpoint (2.5.0)
+ sass (~> 3.3)
+ sassy-maps (< 1.0.0)
chunky_png (1.3.4)
compass-core (1.0.3)
multi_json (~> 1.0)
@@ -13,13 +16,22 @@ GEM
rb-inotify (0.9.5)
ffi (>= 0.5.0)
sass (3.4.13)
+ sassy-maps (0.4.0)
+ sass (~> 3.3)
+ susy (2.2.6)
+ sass (>= 3.3.0, < 3.5)

PLATFORMS
ruby

DEPENDENCIES
+ breakpoint (>= 2.5.0)
chunky_png (~> 1.2)
compass-core (~> 1.0.2)
compass-import-once (~> 1.0.5)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
+ susy (>= 2.2.6)

egore911 commented on 2015-09-18 08:22

I'm constantly getting:

LoadError on line ["179"] of /usr/lib/ruby/gems/2.2.0/gems/compass-1.0.3/vendor/bundle/ruby/2.2.0/gems/compass-core-1.0.3/lib/compass/configuration/data.rb: cannot load such file -- breakpoint

It seems to be by a broken(?) sass dependency as mentioned here: http://stackoverflow.com/questions/18373644/trouble-running-compass-on-osx-loaderror-on-line-51

Any chance to fix this in the package? Or is it an upstream bug?

For me this can be fixes by extending Gemfile:

gem 'breakpoint', ">=2.5.0"
gem 'sassy-maps', ">=0.4.0"
gem 'susy', ">=2.2.6"

and Gemfile.lock:

breakpoint (2.5.0)
sassy-maps (0.4.0)
susy (2.2.6)

egore911 commented on 2015-09-18 07:34

I'm constantly getting:

LoadError on line ["179"] of /usr/lib/ruby/gems/2.2.0/gems/compass-1.0.3/vendor/bundle/ruby/2.2.0/gems/compass-core-1.0.3/lib/compass/configuration/data.rb: cannot load such file -- breakpoint

It seems to be by a broken(?) sass dependency as mentioned here: http://stackoverflow.com/questions/18373644/trouble-running-compass-on-osx-loaderror-on-line-51

Any chance to fix this in the package? Or is it an upstream bug?

krevedko commented on 2014-12-19 07:37

Flagged out-of-date, because it does not build. Same error as in previous comments.

dxxvi commented on 2014-12-16 02:55

I had the same issue as justforgetme.

justforgetme commented on 2014-12-03 12:57

I'm getting following Error:
[code]
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your
bundle as root will break this application for all non-root users on this machine.
You are trying to install in deployment mode after changing
your Gemfile. Run `bundle install` elsewhere and add the
updated Gemfile.lock to version control.

You have added to the Gemfile:
* sass (< 3.5, >= 3.3.13)

You have deleted from the Gemfile:
* sass (< 3.5, >= 3.3.13)
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build ruby-compass.
[/code]

mtorromeo commented on 2014-03-19 13:48

Done, it seems to be working here and hopefully I didn't break anything.

All comments