Package Details: ruby-fog 1.36.0-2

Git Clone URL: https://aur.archlinux.org/ruby-fog.git (read-only)
Package Base: ruby-fog
Description: brings clouds to you
Upstream URL: http://github.com/fog/fog
Keywords: gem ruby
Licenses: MIT
Submitter: masterkorp
Maintainer: CarstenF
Last Packager: CarstenF
Votes: 2
Popularity: 0.023221
First Submitted: 2012-07-11 10:42
Last Updated: 2015-11-30 14:49

Latest Comments

enderst commented on 2015-08-14 03:34

error: target not found: ruby-fog-powerdns
error: target not found: ruby-fog-storm_on_demand
error: target not found: ruby-fog-terremark
error: target not found: ruby-fog-voxel
error: target not found: ruby-fog-serverlove
error: target not found: ruby-fog-vmfusion
error: target not found: ruby-fog-riakcs
error: target not found: ruby-fog-radosgw
error: target not found: ruby-fog-sakuracloud
error: target not found: ruby-fog-profitbricks

andybz commented on 2013-07-23 00:37

Here's the PKGBUILD diff to get fog updated to 1.14

--- PKGBUILD 2013-03-23 09:18:02.000000000 +1100
+++ PKGBUILD.update 2013-07-23 10:36:39.835228996 +1000
@@ -2,7 +2,7 @@

_gemname=fog
pkgname=ruby-$_gemname
-pkgver=1.10.0
+pkgver=1.14.0
pkgrel=1
pkgdesc="Brings clouds to you"
arch=('any')
@@ -11,18 +11,18 @@
depends=(
'ruby'
'ruby-builder>=0'
- 'ruby-excon>=0.14.0'
+ 'ruby-excon>=0.25.0'
'ruby-formatador>=0.2.0'
'ruby-multi_json>=1.0'
'ruby-mime-types>=0'
- 'ruby-net-scp>=1.0.4'
+ 'ruby-net-scp>=1.1.0'
'ruby-net-ssh>=2.1.3'
'ruby-nokogiri>=1.5.0'
'ruby-hmac>=0')
makedepends=('rubygems')
source=(http://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
-md5sums=('03de941cb26505a5b612f6d42f52f332')
+sha1sums=('276c0c631dd168172a7b9403e403ad47404829e4')

package() {
cd "$srcdir"

andybz commented on 2013-07-23 00:34

This is an updated PKGBUILD to bring fog up to 1.14

_gemname=fog
pkgname=ruby-$_gemname
pkgver=1.14.0
pkgrel=1
pkgdesc="Brings clouds to you"
arch=('any')
url="http://github.com/fog/fog"
license=('MIT')
depends=(
'ruby'
'ruby-builder>=0'
'ruby-excon>=0.25.0'
'ruby-formatador>=0.2.0'
'ruby-multi_json>=1.0'
'ruby-mime-types>=0'
'ruby-net-scp>=1.1.0'
'ruby-net-ssh>=2.1.3'
'ruby-nokogiri>=1.5.0'
'ruby-hmac>=0')
makedepends=('rubygems')
source=(http://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)
sha1sums=('276c0c631dd168172a7b9403e403ad47404829e4')

package() {
cd "$srcdir"
local _gemdir="$(ruby -e'puts Gem.default_dir')"
gem install --ignore-dependencies --no-user-install -i "$pkgdir$_gemdir" $_gemname-$pkgver.gem
}

sakaru commented on 2013-07-11 13:38

I think the ruby-nokogiri dependency should be changed to ruby-nokogiri-1.5.