Package Details: ruby-gollum 4.1.4-2

Git Clone URL: https://aur.archlinux.org/ruby-gollum.git (read-only)
Package Base: ruby-gollum
Description: A simple, Git-powered wiki.
Upstream URL: http://github.com/gollum/gollum
Licenses: MIT
Submitter: greyltc
Maintainer: jamincollins
Last Packager: jamincollins
Votes: 0
Popularity: 0.000000
First Submitted: 2017-02-27 03:01
Last Updated: 2019-07-01 14:45

Latest Comments

sphakka commented on 2019-09-16 16:28

Still missing dep (using yay):

==> Validating source files with sha256sums...
    gollum-4.1.4.gem ... Passed
    omnigollum-support.patch ... Passed
    sinatra-1.4.4.gem ... Passed
    sanitize-2.1.1.gem ... Passed
    twitter-text-1.14.7.gem ... Passed
    unf-0.1.0.gem ... Passed
    unf_ext-0.0.7.6.gem ... Passed
    tilt-1.3.4.gem ... Passed
    rack-protection-1.4.0.gem ... Passed
==> Cleaning up...
==> Making package: ruby-nokogiri 1.10.4-0 (2019-09-16T18:10:22 CEST)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> ruby-mini_portile2
==> Checking buildtime dependencies...
==> ERROR: Could not resolve

And, after manually installing ruby-mini_portile2, trying manually ruby-gollum-lib

==> Missing dependencies:
  -> ruby-gollum-grit_adapter
  -> ruby-sanitize
  -> ruby-github-markup

That goes through, but then I get:

$ gollum .
Traceback (most recent call last):
    12: from /usr/bin/gollum:23:in `<main>'
    11: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `activate_bin_path'
    10: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `synchronize'
     9: from /usr/lib/ruby/2.6.0/rubygems.rb:305:in `block in activate_bin_path'
     8: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1417:in `activate'
     7: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `activate_dependencies'
     6: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `each'
     5: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1449:in `block in activate_dependencies'
     4: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1417:in `activate'
     3: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `activate_dependencies'
     2: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1435:in `each'
     1: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1446:in `block in activate_dependencies'
/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'rouge' (~> 2.1) - did find: [rouge-3.3.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/marcoep/.gem/ruby/2.6.0:/usr/lib/ruby/gems/2.6.0', execute `gem env` for more information

It really needs

$ yay ruby-rouge-2.1

and it works :-)

jamincollins commented on 2019-06-24 15:12

Updated PKGBUILD for gollum 4.1.4. It should met all dependencies and be functional after build/install.

jamincollins commented on 2019-06-23 19:09

I've updated the 4.1.2 package so it should be functional after install (all dependencies properly met). I'll see about getting a functional PKGBUILD for 4.1.4 soon.

sasvari commented on 2019-04-25 10:02

missing dependencies (at least for 4.1.4):

ruby-mime-types-1.19
ruby-posix-spawn
ruby-rouge-2.1
ruby-stringex

still complains about ruby sanitize, though.

noraj commented on 2019-02-07 23:49

I made a PKGBUILD for 4.1.4 but most of dependencies are too old. In the meantime you can use this:

# Maintainer: noraj <printf %s 'YWxleGFuZHJlLnphbm5pQGV1cm9wZS5jb20='|base64 -d>

_gemname=gollum
pkgname=ruby-$_gemname
pkgver=4.1.4
pkgrel=1
pkgdesc='A simple, Git-powered wiki.'
arch=(any)
url='http://github.com/gollum/gollum'
license=(MIT)
depends=('ruby>=1.9'
     'ruby-gollum-lib>=4.2.10'
     'ruby-gollum-lib<5'
     'ruby-kramdown>=1.9.0'
     'ruby-kramdown<1.10'
     'ruby-sinatra>=1.4.4'
     'ruby-sinatra<2' 
     'ruby-mustache>=0.99.5'
     'ruby-mustache<1'
     'ruby-useragent>=0.16.2'
     'ruby-useragent<0.17'
     'ruby-gemojione>=3.2'
     'ruby-gemojione<4')
options=(!emptydirs)
source=(https://rubygems.org/downloads/$_gemname-$pkgver.gem)
noextract=($_gemname-$pkgver.gem)

package() {
  local _gemdir="$(ruby -e'puts Gem.default_dir')"

  gem install --ignore-dependencies --no-user-install -i "$pkgdir/$_gemdir" -n "$pkgdir/usr/bin" $_gemname-$pkgver.gem

  rm -rf "$pkgdir/$_gemdir/cache"
  install -D -m644 "$pkgdir/$_gemdir/gems/$_gemname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}

sha256sums=('87c2dc6c68c91a423727a59b9d3e78e9e4656e2308065a1d779dd1711c586146')

bertptrs commented on 2017-08-08 08:20

Thanks for spotting, should be fixed now.

greyltc commented on 2017-08-08 07:58

there's a typo in the source URL

bertptrs commented on 2017-08-07 15:17

Version 4.1.1 is now packaged, but due to dependencies it is packaged a little weird. Users having trouble upgrading are recommended to first remove ruby-gollum and ruby-gollum-lib before installing it again due to a file conflict.

I will probably release some tweaks in the coming days since I'm not quite content with how it's done at the moment, but this is a quick fix for now.

carbolymer commented on 2017-07-21 08:57

4.1.0 is available since March 2017. Now It's July. when this package will be updated?

bertptrs commented on 2017-06-08 12:05

This package installs all these gems included, but most of these are available as either AUR or regular packages, which should be used instead.

See:
aur/gemojione
aur/kramdown
aur/ruby-mini_portile
community/ruby-mustache
aur/ruby-nokogiri
community/rack
aur/ruby-rouge
aur/ruby-sanitize (possibly too new, since it is at version 4.0)