Package Details: ruby-gstreamer 3.4.9-1

Git Clone URL: https://aur.archlinux.org/ruby-gstreamer.git (read-only, click to copy)
Package Base: ruby-gstreamer
Description: Ruby/GStreamer is a Ruby binding for GStreamer.
Upstream URL: http://ruby-gnome2.osdn.jp/
Licenses: LGPL
Submitter: bender02
Maintainer: stig124
Last Packager: stig124
Votes: 32
Popularity: 0.000000
First Submitted: 2009-06-20 15:12 (UTC)
Last Updated: 2021-08-10 11:50 (UTC)

Latest Comments

jamesan commented on 2015-01-25 00:12 (UTC)

Nm... I adopted this package and updated it as per my previous comment. =)

jamesan commented on 2015-01-25 00:04 (UTC)

The latest upstream version is now 2.2.4 (we're at 2.0.2 at the moment) and this PKGBUILD is missing a make dependency on ruby-pkgconfig found in the official repos. With that makedepends, the --ignore-dependencies flag on the gem install command works. I've an updated PKGBUILD that includes a few other tweaks in keeping with the current packaging guidelines. You can find the PKGBUILD and diff of changes here: PKGBUIOLD => http://goo.gl/Kr85rq Change diff => http://goo.gl/RmKmbQ

dvogel commented on 2014-11-03 14:48 (UTC)

Had the same issue as Ps0ke : Removed --ignore-dependencies in PKGBUILD > package() > gem ....

GloW commented on 2014-10-10 09:49 (UTC)

Nevermind, it build allright, but cannot be loaded in ruby. /usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'glib2' (= 2.0.2) among 11 total gem(s) (Gem::LoadError) from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate' from /usr/lib/ruby/2.1.0/rubygems.rb:196:in `rescue in try_activate' from /usr/lib/ruby/2.1.0/rubygems.rb:193:in `try_activate' from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:132:in `rescue in require' from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:144:in `require' from test:2:in `<main>'

GloW commented on 2014-10-10 08:24 (UTC)

Removing and installing ruby-glib2 did the trick.

GloW commented on 2014-10-02 11:16 (UTC)

Fail tu build here, same error.

Ps0ke commented on 2014-06-19 17:19 (UTC)

Fails to build on my machine (with yaourt). Error log is here: http://pastie.org/9305852 the log file mentioned in the end contains: http://pastie.org/9305854

rekado commented on 2011-08-15 10:22 (UTC)

reverted PKGBUILD to build native extension instead of using the gem.

rekado commented on 2011-08-12 23:56 (UTC)

added missing dependency. Thanks sarnaud.

commented on 2011-08-12 20:22 (UTC)

There is a missing makedepends on ruby-pkgconfig in the PKGBUILD.

rekado commented on 2011-08-12 15:31 (UTC)

updated to 1.0.0 version. Installing from gem now.

KaoDome commented on 2011-05-18 14:47 (UTC)

0.90.8 is the latest stable version upstream.