Package Details: ruby-haste-git latest-1

Git Clone URL: https://aur.archlinux.org/ruby-haste-git.git (read-only)
Package Base: ruby-haste-git
Description: Simple client for uploading text to a haste-server (hastebin) (development version)
Upstream URL: https://github.com/seejohnrun/haste-client
Licenses: MIT
Conflicts: ruby-haste
Provides: ruby-haste
Submitter: neersighted
Maintainer: neersighted
Last Packager: neersighted
Votes: 1
Popularity: 0.000000
First Submitted: 2013-03-01 06:47
Last Updated: 2015-06-09 15:34

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

brenns10 commented on 2015-01-03 20:32

I believe that ruby-faraday should be added as a dependency. I got this error when I ran haste after install:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'faraday' (~> 0.9) among 48 total gem(s) (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/haste:22:in `<main>'

brenns10 commented on 2015-01-03 20:31

I believe that this depends on ruby-faraday should be added as a dependency. I got the following error on install:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'faraday' (~> 0.9) among 48 total gem(s) (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/haste:22:in `<main>'

neersighted commented on 2013-03-01 06:52

Created.

* This PKGBUILD now requires Pacman 4.1, due to be released March 10. If you don't know how/can't build it, contact me for a backported PKGBUILD.