Package Details: ruby-jekyll 3.6.0-1

Git Clone URL: https://aur.archlinux.org/ruby-jekyll.git (read-only)
Package Base: ruby-jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Licenses: MIT
Submitter: oliparcol
Maintainer: CarstenF
Last Packager: CarstenF
Votes: 61
Popularity: 1.206125
First Submitted: 2010-12-14 20:45
Last Updated: 2017-10-01 11:57

Latest Comments

patrick.luehne commented on 2017-10-10 22:30

Please fix the dependency to liquid ≥ 4.0.0 in the PKGBUILD.

Concerning the Liquid dependency, I added an AUR package called ruby-liquid containing the required version (4.0.0).

I believe the dependencies should now read:

depends=('ruby' 'ruby-addressable>=2.4' 'ruby-colorator>=1.0' 'ruby-jekyll-sass-converter>=1.0' 'ruby-jekyll-watch>=1.1' 'ruby-kramdown>=1.14' 'ruby-liquid>=4.0' 'ruby-mercenary>=0.3.3' 'ruby-pathutil>=0.9' 'ruby-rouge-2.0' 'ruby-safe_yaml>=1.0')

Let me know if I can be of any help :). Thanks!

patrick.luehne commented on 2017-10-03 23:17

Dear maintainers,

Jekyll as of version 3.6.0 has multiple dependencies that are currently not met by this package [1].

The following dependencies are missing or outdated:

* ruby-kramdown (1.14 required but only 1.10 in the AUR, I already contacted the maintainers)
* ruby-liquid (4.0 required but only 3.0.6 in the AUR, a new package might be necessary)

I suggest adding the required minimal versions to the PKGBUILD dependencies exactly as listed in the gemspec [1]. Concerning liquid 4, I’m not sure whether it should be a package separate from ruby-liquid-3, or whether there should be only one ruby-liquid package at some point. What do you think?

Best wishes,
Patrick




[1] https://github.com/jekyll/jekyll/blob/master/jekyll.gemspec#L33-L43

jplatte commented on 2017-09-21 18:04

Yes, the 'jekyll new' template uses bundler to install the minima theme. But jekyll can be used without themes nevertheless.

yair commented on 2017-09-21 12:19

seems bundler is a requirement, also mentioned in the jekyll quick start page

```➜ jekyll new blog
Dependency Error: Yikes! It looks like you don't have bundler or one of its dependencies installed. In order to use Jekyll as currently configured, you'll need to install this gem.
```

jplatte commented on 2017-08-29 16:25

ber532k: Are you using a theme / plugin? I think jekyll uses bundler to download (and build?) themes and/or plugins. But I'm pretty sure that it's not a hard dependency.

ber532k commented on 2017-08-29 10:47

I just had an issue after installing this package via pacaur. Something about bundler-something not found. Installing ruby-bundler from community (and reinstalling ruby-jekyll) apparently fixed that, so you might consider adding ruby-bundler as a dependency.

CarstenF commented on 2017-04-01 11:00

@andybz and @imrehg: ruby-rouge-1 dependency is fixed now. an ruby-jekyll is update to 3.4.3.

andybz commented on 2017-04-01 03:57

You can fix the error Could not find 'rouge' (~> 1.7) - did find: [rouge-2.0.7] (Gem::MissingSpecVersionError) by installing ruby-rouge-1, but would be great if the maintainer could change the dependency until https://github.com/jekyll/jekyll/pull/5230 is merged.

imrehg commented on 2017-03-26 10:09

Wrong version of rouge is pulled in currently:

/usr/lib/ruby/2.4.0/rubygems/dependency.rb:310:in `to_specs': Could not find 'rouge' (~> 1.7) - did find: [rouge-2.0.7] (Gem::MissingSpecVersionError)

zasdfgbnm commented on 2016-08-11 17:24

Please update the dependency list
See:
https://rubygems.org/gems/jekyll

All comments