Package Details: ruby-jekyll 3.2.0-1

Git Clone URL: https://aur.archlinux.org/ruby-jekyll.git (read-only)
Package Base: ruby-jekyll
Description: A simple, blog aware, static site generator.
Upstream URL: https://github.com/jekyll/jekyll
Licenses: MIT
Submitter: oliparcol
Maintainer: CarstenF
Last Packager: CarstenF
Votes: 48
Popularity: 0.640388
First Submitted: 2010-12-14 20:45
Last Updated: 2016-07-29 15:57

Latest Comments

zasdfgbnm commented on 2016-08-11 17:24

Please update the dependency list
See:
https://rubygems.org/gems/jekyll

jleclanche commented on 2016-07-31 19:05

Edit: Ruby-colorator dependency seems broken. It's not finding it.

CarstenF commented on 2016-04-01 14:16

@fusion809, Thanks for your report. I have changed the url and updated to the new version.

fusion809 commented on 2016-04-01 05:57

@CarstenF, I know this is a minor detail, but you may wish to note that the Jekyll GitHub repo is now at https://github.com/jekyll/jekyll and not http://github.com/mojombo/jekyll. Jekyll also has its own website at http://jekyllrb.com. Jekyll 3.1.2 is now out too.

caleb commented on 2016-03-14 14:54

This needs to have dependencies added for ruby-rb-{fsevent,inotify}.

CarstenF commented on 2016-02-09 15:01

Package Update to 3.1.1

sleeping commented on 2016-02-03 22:06

I had to install a whole bunch of gems manually, after that I had to downgrade Celluloid with

gem install celluloid --version 0.16.0
gem uninstall celluloid --version 0.17.3

Works now!

CarstenF commented on 2016-01-27 10:06

The Update of the Package is WIP. But I can not upload it. If I find the Problem I will push the Update

kseistrup commented on 2015-12-23 10:09

The official version is now 3.0.1. Could the maintainer please update this package? Cheers.

hobarrera commented on 2015-08-24 23:03

Manually maintaining a pile of ruby-* packages is a PITA. I recently discovered an Arch repo that contains binary packages for these, automatically generated, and maintained by one of the Arch devs (so we might as well trust it).

I recommend that you prefer it instead of using the AUR:

https://github.com/anatol/quarry

I'll be orphaning this now, so feel free to pick it up if you don't care much about my above advise.

Note that I've updated jekyll and all it's dependencies too, so it's safe to keep using this anyway.

hobarrera commented on 2015-08-24 22:45

I uninstalled every single ruby package and reinstalled them. Looks like jekyll-sass was missing from the dependency tree.

kitarek commented on 2015-08-24 19:37

@hobarrera - Thanks very much. `jekyll serve` is still reporting for me missing `RedCloth-4.2.9` dependency.

I'm not sure if it's related to some packages not rebuilt today on my side. I have rebuilt `rebu-jekyll` (and its new deps) as well as `ruby-jekyll-watch` (deps: -listen).

Thanks a lot!

hobarrera commented on 2015-08-24 17:39

I've updated this package and several of its dependencies.

Thanks for all the detailed messages. I hope I didn't miss uploading anything (it's kinda hard to keep track of what's uploaded and what's not).

mschu commented on 2015-08-17 23:13

celluloid needs to be version 16 as well: https://talk.jekyllrb.com/t/error-while-trying-to-run-jekyll-serve/933/8

sorry for spamming you so much, let me know if you need help fixing the deps :-)

mschu commented on 2015-08-17 23:05

And further celluloid, rspec-logsplit, hitimes, timers, celluloid-extras, celluloid-fsm, celluloid-pool, celluloid-supervision, celluloid-essentials, bundler, nenv, dotenv, rb-fsevent, ffi, rb-inotify.

And community/nodejs or another JS framework as ItachiSan pointed out.

mschu commented on 2015-08-17 22:51

I still get an error message when running Jekyll in my page directory:

/usr/lib/ruby/2.2.0/rubygems/dependency.rb:315:in `to_specs': Could not find 'jekyll-sass-converter' (~> 1.0) among 30 total gem(s) (Gem::LoadError)

Seems to need a depends on ruby-jekyll-sass-converter. And ruby-jekyll-watch, which is missing ruby-listen (there is already a comment on the package).

hobarrera commented on 2015-08-14 02:20

Just pushed ruby-kramdown. Thanks for the heads up.

mschu commented on 2015-08-09 22:00

This is missing at least the ruby-kramdown dependency in AUR4.

ItachiSan commented on 2015-07-24 15:14

And also a JavaScript environment, else Jekyll won't run. Actually, 'nodejs' from community works fine.

ItachiSan commented on 2015-07-24 15:04

You should add 'ruby-jekyll-sass-converter' as a dependency.

kralyk commented on 2015-05-19 01:18

@anatolik Thanks, that's great!

hobarrera commented on 2015-05-16 20:20

(or viceversa)

hobarrera commented on 2015-05-16 20:20

I admit that current packaging is awful. I'm willing to merge all this into a single package, *however*, is there any valid scenario under which someone would use ruby-jekyll-less, without ruby-jekyll?

anatolik commented on 2015-05-16 16:19

Manually maintaining correct deps for gem packages is hard

Good news - there is a binary gem repo from me (maintainer of ruby in Arch) that has jekyll with correct dependencies https://wiki.archlinux.org/index.php/Unofficial_user_repositories#quarry Dependencies are automatically generated from gemspec.

kralyk commented on 2015-05-11 14:42

The amount of packages this package depends on is absolutely ridiculous.

ruby-jekyll actually seemds to depend on some of the packages that are listed as "Required by" here, namely ruby-jekyll-coffeescript, ruby-jekyll-gist, ruby-jekyll-paginate and ruby-jekyll-watch.

Could these be made part of this package? IMHO it doesn't make much sense having them as seperate packages, since it creates a circular dependency.

orschiro commented on 2014-10-27 20:00

@anatolik

Thank you for adding the dependency!

anatolik commented on 2014-10-27 19:34

Per popular request I added 'nodejs' to the dependency list of 'ruby-execjs'. Now everyone who installs jekyll will install nodejs as well.

orschiro commented on 2014-10-26 12:16

Adding `nodejs` as a dependency does fix my previously reported issue.

orschiro commented on 2014-10-26 10:59

I cannot launch jekyll. It misses a JavaScript runtime. Anyone with the same issue?

/usr/lib/ruby/gems/2.1.0/gems/execjs-2.2.2/lib/execjs/runtimes.rb:51:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

hobarrera commented on 2014-09-11 13:53

I believe this package should be called "jekyll", instead of "ruby-jekyll": https://wiki.archlinux.org/index.php/Ruby_Gem_Package_Guidelines#Package_naming

Darkhogg commented on 2014-08-04 11:09

Jekyll 2.2.0 has been out for a week now: http://jekyllrb.com/news/2014/07/29/jekyll-2-2-0-released/

nickoe commented on 2014-07-27 13:20

cd blog before build

nickoe commented on 2014-07-27 13:20

cd blog bevore build

probil commented on 2014-07-27 12:59

I have some trouble. How to fix it?

> jekyll new blog
New jekyll site installed in /home/maks/blog.
> jekyll build -d ./blog
Configuration file: none
Source: /home/maks
Destination: ./blog
Generating...
jekyll 2.1.1 | Error: No such file or directory @ rb_sysopen - /home/maks/Документи/pkg/lib32-curl/usr/share/licenses/lib32-curl

hobarrera commented on 2014-07-13 17:00

Depends missing: ruby-listen.

anatolik commented on 2014-07-09 13:42

Sorry for missed dependencies. Added them to AUR as well.

hahnjo commented on 2014-07-09 07:05

It cannot find ruby-jekyll-paginate (there is ruby-jekyll-pagination), ruby-jekyll-gist nor ruby-jekyll-watch...

anatolik commented on 2014-06-13 03:35

FYI I created a binary rubygems repo that also includes jekyll https://bbs.archlinux.org/viewtopic.php?id=182729

anatolik commented on 2014-06-12 12:03

Oops, sorry, ruby-pygments-0.5 is added.

nickoe commented on 2014-06-12 11:52

ruby-pygments-0.5 is not found, but whouldn't it be ruby-pygments?

anatolik commented on 2014-06-07 19:31

jekyll does not depend on nodejs - execjs does. In fact it already has nodejs in optdepends https://aur.archlinux.org/packages/ruby-jekyll/

Kuci commented on 2014-06-07 17:34

Please, add nodejs to dependency list.

nickoe commented on 2014-05-18 18:32

OK

veox commented on 2014-05-18 18:28

@nickoe: this will be fixed in the next release: https://github.com/jekyll/jekyll/commit/ceb27fb9a2850e148eac0f02eccc9f6070469036

nickoe commented on 2014-05-17 08:03

I needed to install nodejs, maybe you should add that to the depends array.

nickoe commented on 2014-05-17 07:57

I just installed this package and it depends on a clean system and I get the following error.

$ jekyll --help
/usr/lib/ruby/gems/2.1.0/gems/execjs-2.0.2/lib/execjs/runtimes.rb:51:in `autodetect': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)
from /usr/lib/ruby/gems/2.1.0/gems/execjs-2.0.2/lib/execjs.rb:5:in `<module:ExecJS>'
from /usr/lib/ruby/gems/2.1.0/gems/execjs-2.0.2/lib/execjs.rb:4:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/jekyll-coffeescript-1.0.0/lib/jekyll-coffeescript.rb:2:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/jekyll-2.0.3/lib/jekyll.rb:73:in `<top (required)>'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from /usr/lib/ruby/gems/2.1.0/gems/jekyll-2.0.3/bin/jekyll:6:in `<top (required)>'
from /usr/bin/jekyll:23:in `load'
from /usr/bin/jekyll:23:in `<main>'

anatolik commented on 2014-05-14 16:03

> +1 for ruby-celluloid-io.

ruby-listen package misses this dependency. I added a comment on their page. https://aur.archlinux.org/packages/ruby-listen/

I wish everyone use gem2arch to track the gem dependencies. AUR ruby gems were much more usable in this case.

anatolik commented on 2014-05-14 15:49

> Could not find 'parslet' (~> 1.5.0) - did find: [parslet-1.6.0] (Gem::LoadError)

jekyll depends on parslet-1.5 via ruby-toml. Are you sure you have all your dependencies up-to-date?

bchretien commented on 2014-05-13 09:10

+1 for ruby-celluloid-io. I also had a problem with ruby-parslet:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'parslet' (~> 1.5.0) - did find: [parslet-1.6.0] (Gem::LoadError)

alexod commented on 2014-05-09 02:01

anatolik thank you.

I noticed that jekyll also requires ruby-celluloid-io (I do not know whether I requires it directly or via some other dependency) and that execjs requires a javascript runtime (that I reported to that package).

anatolik commented on 2014-05-08 16:14

As a workaround install ruby-timers-1 package

anatolik commented on 2014-05-08 15:51

Yes, the problem is with ruby-celluloid package that pulls wrong dependencies. It should be reported there.

alexod commented on 2014-05-08 15:20

After upgrading I get the following error:

/usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'timers' (~> 1.1.0) - did find: [timers-2.0.0] (Gem::LoadError)
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies'
from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate'
from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem'
from /usr/bin/jekyll:22:in `<main>'

It seems that the wrong version of ruby-timers is in aur. Since the dependency on ruby-timer is indirect via ruby-celluloit, this is probably a bug in this package.

anatolik commented on 2013-12-16 07:17

btw I can take this and other your gems. I mostly scripted the gem->arch maintenance tasks.

anatolik commented on 2013-12-16 07:16

The "~>" version restriction does not map to Arch model directly. One needs to use "versioned packages"

https://wiki.archlinux.org/index.php/Ruby_Gem_Package_Guidelines#Versioned_packages

oliparcol commented on 2013-08-18 12:09

thank you, I will take a look

rberaldo commented on 2013-08-14 23:20

This might be of help: https://aur.archlinux.org/packages/pacgem/.

oliparcol commented on 2013-06-24 11:47

Hello,

Sorry for the delay. I'm open to suggestion but I don't know if it's really recommended to implement a bundle in a AUR package...

Do you have example of official archlinux ruby packages using a bundle (or a virtualenv for python) ?

thank you,

Muflone commented on 2013-06-24 11:42

This package unfortunately cannot work as long as it has so many external dependencies with specific versions.

I hope you could accept the suggest from artafinde.

artafinde commented on 2013-06-17 19:19

Can we make this use bundle as suggested on the bug:
https://github.com/plusjade/jekyll-bootstrap/issues/150

oliparcol commented on 2013-06-09 09:51

sorry for the delay, I just updated the package version to 1.0.3

and again, some AUR dependencies don't have the correct version

oliparcol commented on 2013-05-28 05:53

hello,

sorry about the dependencies but as gem is checking the version of dependencies, jekyll won't start unless the dependencies have the exact version number stipulated in the PKGBUILD...

artafinde commented on 2013-05-19 19:53

The package doesn't build anymore as the dependencies cannot be found:
error: target not found: ruby-commander>=4.1.3
error: target not found: ruby-safe_yaml=0.7.0
error: target not found: ruby-directory_watcher=1.4.1
error: target not found: ruby-pygments.rb=0.4.2

oliparcol commented on 2013-04-15 18:50

0.12.1-2: added --no-user-install parameter.

thank you

oliparcol commented on 2013-04-11 08:18

I will update the packages this week-end. thank you

hcartiaux commented on 2013-04-09 23:06

Please, add the parameter --no-user-install to your gem install cmd

oliparcol commented on 2013-02-26 20:11

Updated to the 0.12.1 version.

Kramdown 0.14 is now supported.

oliparcol commented on 2013-01-19 12:58

I just updated ruby-jekyll to the latest version.

Please note: due to this bug (https://github.com/mojombo/jekyll/issues/734#issue-ref-33517105), the ruby-kramdown version needs to be included between 0.13.4 and 0.13.7

oliparcol commented on 2012-10-19 10:09

The new version include the LICENSE file to avoid any resolution problem in github.

oliparcol commented on 2012-10-04 08:34

you're right, I will include the LICENCE file in the AUR package

srl commented on 2012-10-04 07:59

==> Retrieving Sources...
-> Found jekyll-0.11.2.gem
-> Found LICENSE
==> Validating source files with md5sums...
jekyll-0.11.2.gem ... Passed
LICENSE ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build ruby-jekyll.

It's probably a bad idea to have the URL be raw/master instead of a specific commit/tag, for this reason.

oliparcol commented on 2012-08-19 09:36

Jekyll now depends on ruby-kramdown instead of ruby-kramdown-last

oliparcol commented on 2011-12-25 11:14

sorry for the delay... latest version of jekyll is 0.11.0, the version used by rack is the 0.6.2 but I suppose it will work with the latest one.

How different versions of jekyll work together, I don't know... I think the best thing to do is either use gem mechanism or AUR but using both might be a bad idea... It's quite easy to build a new AUR package for rack-jekyll which will check for ruby-jekyll dependency in AUR.

For syntax highlighting, the only package which isn't needed is ruby-albino, you can just remove it from the PKGBUILD file if you don't need it.

hendry commented on 2011-12-02 06:01

I don't understand how gems/Arch packages work together.

sudo gem install rack-jekyll, installed:
Successfully installed jekyll-0.6.2
Successfully installed rack-1.2.4
Successfully installed rack-jekyll-0.3.7

How does ruby-jekyll 0.11.0-3 work with "jekyll-0.6.2"?


Another question is if I just want to use markdown with jekyll and no syntax highlighting, why do I have to install all the deps?

oliparcol commented on 2011-07-14 14:17

kramdown version fixed

oliparcol commented on 2011-05-17 14:25

one useless depedency removed

oliparcol commented on 2011-02-21 19:07

done, thanks for the advice!

oliparcol commented on 2011-02-21 19:07

done

oliparcol commented on 2011-02-19 16:39

I will do it as soon as I am back at home after my holidays (1/2 weeks)

shaleny commented on 2011-02-14 16:33

Could you please add '-n "$pkgdir/usr/bin"' to gem command line to install 'jekyll' executable into a common binary directory?