Package Details: ruby-json-1 1.8.6-2

Git Clone URL: https://aur.archlinux.org/ruby-json-1.git (read-only, click to copy)
Package Base: ruby-json-1
Description: JSON Implementation for Ruby
Upstream URL: http://flori.github.com/json
Licenses: ruby
Provides: ruby-json
Submitter: farwayer
Maintainer: None
Last Packager: farwayer
Votes: 4
Popularity: 0.000000
First Submitted: 2017-01-10 03:17 (UTC)
Last Updated: 2020-06-16 20:12 (UTC)

Dependencies (1)

Required by (14)

Sources (1)

Latest Comments

jose1711 commented on 2022-11-23 19:54 (UTC)

installing this breaks vagrant:

$ vagrant
/usr/lib/ruby/gems/3.0.0/gems/json-1.8.6/lib/json/common.rb:155:in `initialize': wrong number of arguments (given 2, expected 1) (ArgumentError)
    from /usr/lib/ruby/gems/3.0.0/gems/json-1.8.6/lib/json/common.rb:155:in `new'
    from /usr/lib/ruby/gems/3.0.0/gems/json-1.8.6/lib/json/common.rb:155:in `parse'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant/plugin/state_file.rb:20:in `initialize'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant/plugin/manager.rb:37:in `new'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant/plugin/manager.rb:37:in `initialize'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant/plugin/manager.rb:27:in `new'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant/plugin/manager.rb:27:in `instance'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/plugins/guests/alpine/plugin.rb:50:in `check_community_plugin'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/plugins/guests/alpine/plugin.rb:63:in `<class:Plugin>'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/plugins/guests/alpine/plugin.rb:5:in `<module:GuestAlpine>'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/plugins/guests/alpine/plugin.rb:4:in `<module:VagrantPlugins>'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/plugins/guests/alpine/plugin.rb:3:in `<top (required)>'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant.rb:327:in `load'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant.rb:327:in `block in <top (required)>'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant.rb:344:in `each'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant.rb:344:in `block in <top (required)>'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant.rb:336:in `each'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/lib/vagrant.rb:336:in `<top (required)>'
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:160:in `require'
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:160:in `rescue in require'
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:149:in `require'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/bin/vagrant:111:in `<main>'
<internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require': cannot load such file -- vagrant (LoadError)
    from <internal:/usr/lib/ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
    from /opt/vagrant/embedded/gems/2.3.3/gems/vagrant-2.3.3/bin/vagrant:111:in `<main>'

microe commented on 2020-06-07 20:32 (UTC)

I recently tried to install this package on aarch64 and the arch is marked x86_64 and i686, but if I change arch to "any" and run makepkg, this builds fine. Would it be possible to get the arch changed to any for this package?