Package Details: ruby-libglade 0.90.5-1

Git Clone URL: https://aur.archlinux.org/ruby-libglade.git (read-only)
Package Base: ruby-libglade
Description: Ruby libglade2 bindings.
Upstream URL: http://ruby-gnome2.sourceforge.jp
Licenses: LGPL
Submitter: ilpianista
Maintainer: phects
Last Packager: phects
Votes: 72
Popularity: 0.000000
First Submitted: 2010-09-02 17:10
Last Updated: 2015-07-05 17:51

Latest Comments

phects commented on 2011-11-05 11:29

libglade is deprecated now.
The last ruby-gnome2 release containing libglade bindings was 0.90.5.

http://en.wikipedia.org/wiki/Glade_Interface_Designer#GtkBuilder

phects commented on 2010-11-04 17:24

done

gborzi commented on 2010-11-04 17:09

ruby-gnome2-all-0.90.5.tar.gz has been released, please update.

phects commented on 2010-10-29 07:15

sure, uploaded ruby-libglade-0.90.4-3.

gborzi commented on 2010-10-28 21:51

ruby-pkgconfig should be in makedepends, not depends.

phects commented on 2010-10-28 21:29

Excellent suggestion. I missed, that there's a PKGBUILD in AUR for the pkg-config gem.

Sloonz commented on 2010-10-28 21:22

Please add ruby-pkgconfig to depends

ei-grad commented on 2010-10-16 19:53

> Build failed, perhaps you have to run "gem install pkg-config" as root.

+1...

ptchinster commented on 2010-10-16 16:37

http://aur.pastebin.com/p8C7tpFi

Build failed, perhaps you have to run "gem install pkg-config" as root.

gborzi commented on 2010-10-10 00:35

Version 0.90.2 has been released.

Anonymous comment on 2010-10-03 16:14

sudo gem install pkg-config

Thats some wizards spells man. Not from this world. I'm not a 'charmed' one. ;)
Still it worked, thanks.

gborzi commented on 2010-09-26 13:46

Hi phects,
although I've read and voted your bug report, I hadn't noticed the pkg-config gem bit. The create_cairo_contect problem occurs when ruby-gtk2 and ruby-pango are compiled with ruby-rcairo not installed.

phects commented on 2010-09-26 13:04

Hey gborzi,

I proposed installing the pkg-config gem as a fix to the ruby-atk package file being empty.

Uploaded the current version of ruby-libglade a few moments ago and borrowed the check on correct building of the .so file from your PKGBUILD for ruby-gconf2.

The create_cairo_contect problem did not occur to me so far.

Regards..

gborzi commented on 2010-09-25 13:41

I've fixed the "create_cairo_context" problem, see my last post on gnome-screenruler.

gborzi commented on 2010-09-25 12:09

Hello phects,
in case you still have problem in compiling this package, please look at the ruby-gconf2 package. Basically, you need to run "gem install pkg-config" as root before building.
I've still the problem with "create_cairo_context" when I run screenruler, do you have any idea on how to fix?

phects commented on 2010-09-24 14:20

I will update to 0.90.1 as soon as the following bug in ruby-atk is fixed:
https://bugs.archlinux.org/task/20931?project=5&string=ruby-atk

phects commented on 2010-09-11 16:08

Thanks for the notification. I saw that, therefor I adopted the package a few hours before your comment ;).

gborzi commented on 2010-09-11 15:02

Ruby-gnome2 0.19.4 has been released. Please update.