Package Details: ruby-libnotify 0.5.1-3

Git Clone URL: (read-only)
Package Base: ruby-libnotify
Description: ruby bindings for libnotify, a library for desktop notifications
Upstream URL:
Licenses: LGPL
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 73
Popularity: 0.000090
First Submitted: 2007-10-30 19:26
Last Updated: 2015-06-11 07:35

Latest Comments

bidulock commented on 2013-04-11 14:48

PKGBUILD must be split into build() and package() to build with makepkg 4.1

synonym24 commented on 2013-04-03 18:24

I've a problem. I'm using pacman-notifier for a long time now. But for a couple of days every time I'm trying to start pacman-notifier, I get this trace:

$ pacman-notifier
/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:110:in `require': cannot load such file -- RNotify (LoadError)
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:110:in `rescue in require'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:35:in `require'
from /usr/lib/ruby/site_ruby/2.0.0/pacman_notifier/gui/gtk.rb:2:in `<top (required)>'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/lib/ruby/site_ruby/2.0.0/pacman_notifier.rb:6:in `<top (required)>'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
from /usr/bin/pacman-notifier:3:in `<main>'

Something is wrong here with the RNotify library. Is anybody able to point me in the right direction for this?

Anonymous comment on 2012-11-24 17:37


Anonymous comment on 2012-07-06 12:38

well anybody can help? :D

=> Iniciando build()...
WARNING: You don't have /home/x11tete11x/.gem/ruby/1.9.1/bin in your PATH,
gem executables will not run.
Building native extensions. This could take a while...
ERROR: Error installing ruby-libnotify-0.5.0.gem:
ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb
extconf.rb:22: Use RbConfig instead of obsolete and deprecated Config.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

ShyPixie commented on 2012-04-27 04:20

My build failed:

Anonymous comment on 2011-04-04 12:08

Good work !

Anonymous comment on 2011-04-03 20:52

new release!

Anonymous comment on 2011-03-29 20:14

downgrade to libnotify < 0.7 if you want ruby-libnotify to work.. new release coming soon!

Anonymous comment on 2011-02-12 16:07

updated to version

from now on I'll build from gem source

Anonymous comment on 2011-02-07 14:54

ruby-pkgconfig is still missing as dependency.

additionaly I get a certificate problem (should probably rather be fixed by github)

ERROR: certificate common name “*” doesn’t match requested host name “”.
To connect to insecurely, use ‘--no-check-certificate’.

to get around I changed the download url to https instead of http in the PKGBUILD.

All comments