Package Details: ruby-mailcatcher 0.7.1-1

Git Clone URL: https://aur.archlinux.org/ruby-mailcatcher.git (read-only, click to copy)
Package Base: ruby-mailcatcher
Description: Catches mail and serves it through a dream
Upstream URL: https://mailcatcher.me/
Licenses: MIT
Conflicts: mailcatcher
Provides: mailcatcher
Submitter: fzerorubigd
Maintainer: MarsSeed
Last Packager: wget
Votes: 2
Popularity: 0.000000
First Submitted: 2013-05-25 15:58 (UTC)
Last Updated: 2019-09-15 19:17 (UTC)

Pinned Comments

wget commented on 2019-09-15 19:22 (UTC) (edited on 2019-09-15 19:37 (UTC) by wget)

To build this package, please enable the additional third-party repository called "Quarry" (cf. https://wiki.archlinux.org/index.php/Ruby#Quarry) This is the only easy way available we have to build these outdated versions of libs (marked in red in the AUR Web UI above).

Developers wanting a more up to date experience without wanting to play with the Ruby stack or annoyed by memory leaks impacting MailCatcher are encouraged to use MailDev, a new MailCatcher alternative based on nodejs: https://github.com/djfarrelly/MailDev

Latest Comments

1 2 Next › Last »

dampkwab commented on 2022-06-08 05:19 (UTC)

Thanks @MarsSeed. I've added you as a co-maintainer as I have switched to using nodejs-maildev instead.

MarsSeed commented on 2022-06-08 05:11 (UTC)

I've created the ruby-eventmachine-1.0 package too.

MarsSeed commented on 2022-06-07 18:45 (UTC) (edited on 2022-06-07 18:45 (UTC) by MarsSeed)

I've also created a legacy ruby-rack-1 (currently v1.6.13), which should also work with this. Though in theory, ruby-rack 2.x has the same API as 1.x, so this package might as well just depend on ruby-rack.

MarsSeed commented on 2022-06-07 18:42 (UTC) (edited on 2022-06-07 18:45 (UTC) by MarsSeed)

Should declare depends=('ruby-thin>=1.5' 'ruby-thin<1.7'). I've created a new ruby-thin-1.6 pakage which also can satisfy it.

(But please don't link directly to it; use the exact dependency base name /ruby-thin/ as in my example.)

wget commented on 2019-09-15 19:24 (UTC)

Package updated to 0.7.1. We are now using the sources directly as much as possible instead of using the version from RubyGems.

wget commented on 2019-09-15 19:22 (UTC) (edited on 2019-09-15 19:37 (UTC) by wget)

To build this package, please enable the additional third-party repository called "Quarry" (cf. https://wiki.archlinux.org/index.php/Ruby#Quarry) This is the only easy way available we have to build these outdated versions of libs (marked in red in the AUR Web UI above).

Developers wanting a more up to date experience without wanting to play with the Ruby stack or annoyed by memory leaks impacting MailCatcher are encouraged to use MailDev, a new MailCatcher alternative based on nodejs: https://github.com/djfarrelly/MailDev

wget commented on 2018-06-13 15:19 (UTC)

Actually I had a patch on my side for a long time now (2 months already) which is not fully working. I wanted to know why you specified the exact GEM version in the dependency name while it should have been linked to the one provided in AUR?

I know the one in AUR are more recent, but old versions aren't available on rubygem either AFAIK.

I'm just asking because right now, in the current state, the PKGBUILD is not building even if I use the tool carry.

Can someone please explain to me?

dampkwab commented on 2018-06-08 06:01 (UTC) (edited on 2018-06-08 06:06 (UTC) by dampkwab)

To any newcomers:

The dependencies are available from this unofficial package repository: https://wiki.archlinux.org/index.php/Ruby#Quarry

dampkwab commented on 2018-06-08 05:56 (UTC)

Thanks for the patch @jamesan! I've adopted the package, applied your changes and added you as a co-maintainer.