Package Details: ruby-mailcatcher 0.7.1-1

Git Clone URL: https://aur.archlinux.org/ruby-mailcatcher.git (read-only)
Package Base: ruby-mailcatcher
Description: Catches mail and serves it through a dream
Upstream URL: https://mailcatcher.me/
Licenses: MIT
Conflicts: mailcatcher
Provides: mailcatcher
Submitter: fzerorubigd
Maintainer: dampkwab (jamesan, wget)
Last Packager: wget
Votes: 2
Popularity: 0.000000
First Submitted: 2013-05-25 15:58
Last Updated: 2019-09-15 19:17

Pinned Comments

wget commented on 2019-09-15 19:22

To build this package, please enable the additional third-party repository called "Quarry" (cf. https://wiki.archlinux.org/index.php/Ruby#Quarry) This is the only easy way available we have to build these outdated versions of libs (marked in red in the AUR Web UI above).

Developers wanting a more up to date experience without wanting to play with the Ruby stack or annoyed by memory leaks impacting MailCatcher are encouraged to use MailDev, a new MailCatcher alternative based on nodejs: https://github.com/djfarrelly/MailDev

Latest Comments

wget commented on 2019-09-15 19:24

Package updated to 0.7.1. We are now using the sources directly as much as possible instead of using the version from RubyGems.

wget commented on 2019-09-15 19:22

To build this package, please enable the additional third-party repository called "Quarry" (cf. https://wiki.archlinux.org/index.php/Ruby#Quarry) This is the only easy way available we have to build these outdated versions of libs (marked in red in the AUR Web UI above).

Developers wanting a more up to date experience without wanting to play with the Ruby stack or annoyed by memory leaks impacting MailCatcher are encouraged to use MailDev, a new MailCatcher alternative based on nodejs: https://github.com/djfarrelly/MailDev

wget commented on 2018-06-13 15:19

Actually I had a patch on my side for a long time now (2 months already) which is not fully working. I wanted to know why you specified the exact GEM version in the dependency name while it should have been linked to the one provided in AUR?

I know the one in AUR are more recent, but old versions aren't available on rubygem either AFAIK.

I'm just asking because right now, in the current state, the PKGBUILD is not building even if I use the tool carry.

Can someone please explain to me?

dampkwab commented on 2018-06-08 06:01

To any newcomers:

The dependencies are available from this unofficial package repository: https://wiki.archlinux.org/index.php/Ruby#Quarry

dampkwab commented on 2018-06-08 05:56

Thanks for the patch @jamesan! I've adopted the package, applied your changes and added you as a co-maintainer.

jamesan commented on 2018-02-13 15:42

Here's a diff of my suggested updates to this PKGBUILD: https://pastebin.com/5PWqc32i

It updates this package to its latest upstream version, 0.6.5, corrects gem package dependencies, and cleans up the PKGBUILD.

Also, some of the gems whose packages have vanished from the AUR are maintained in a RubyGems binary package repo called Quarry: https://wiki.archlinux.org/index.php/Ruby#Quarry

I've requested to orphan this package to push this update through with the intention of restoring the existing maintainer as a co-maintainer moving forward.

pcarvalho commented on 2016-11-21 19:02

Hi, do you know what happened to:
ruby-haml
ruby-sinatra
ruby-thin
? They're gone from aur

voyd commented on 2016-08-27 22:27

ruby-activesupport-4.2 maintainer here. Please request deletion of ruby-activesupport-4.2 after you updated this to 0.6.5.
After the update, we won't need activesupport-4.2 any more and it's broken anyways.

voyd commented on 2016-07-06 19:05

Activesupport has been upgraded to 5.0.0.

As far as I can tell, this package needs 4.X, so you should depend on ruby-activesupport-4.2 instead.

EDIT: I created activesupport-4.2 in the meantime and filed 4.1 for deletion, so you should use 4.2