Package Details: ruby-mdl 0.11.0-1

Git Clone URL: (read-only, click to copy)
Package Base: ruby-mdl
Description: A lint tool to check markdown files and flag style issues
Upstream URL:
Licenses: MIT
Submitter: berquist
Maintainer: grawlinson
Last Packager: grawlinson
Votes: 2
Popularity: 0.000372
First Submitted: 2017-07-27 13:35 (UTC)
Last Updated: 2021-07-24 12:38 (UTC)

Latest Comments

blueyed commented on 2019-07-29 16:44 (UTC)

I have not tried, but maybe it is just pinned too conservative, and patching this away would make it work. Should be fixed upstream then though also, of course (which appears to be not very active). (also not a Rubyist)

berquist commented on 2019-02-04 02:26 (UTC)

You're right, I didn't notice it because I have mdl run automatically from flycheck in Emacs, and if one of the checkers isn't working, it automatically gets disabled. I get the same error when trying to run it from the command line

I am not a Rubyist, so I don't know if making versioned packages for the two mixlib gems would even work. I am open to suggestions.

lucc commented on 2019-01-25 09:20 (UTC)

I suspect there is a version conflict between the kramdown that mdl requires and the one in the community repo. I just rebuild the ruby-mdl, ruby-mixlib-cli and ruby-mixlib-config and reinstalled ruby-kramdown from the repos. mdl seems to require kramdown at version 1.12 but neither of the packages in the repo or the aur provides that version.

How do you run mdl and does it work for you?

For completeness here is the exception I get when running mdl:

Traceback (most recent call last):
    8: from /usr/bin/mdl:23:in `<main>'
    7: from /usr/lib/ruby/2.6.0/rubygems.rb:303:in `activate_bin_path'
    6: from /usr/lib/ruby/2.6.0/rubygems.rb:303:in `synchronize'
    5: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `block in activate_bin_path'
    4: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1420:in `activate'
    3: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `activate_dependencies'
    2: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `each'
    1: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1449:in `block in activate_dependencies'
/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'kramdown' (>= 1.12.0, ~> 1.12) - did find: [kramdown-2.0.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/luc/.gem/ruby/2.6.0:/usr/lib/ruby/gems/2.6.0', execute `gem env` for more information