Package Details: ruby-mdl 0.5.0-1

Git Clone URL: https://aur.archlinux.org/ruby-mdl.git (read-only)
Package Base: ruby-mdl
Description: Markdown lint tool
Upstream URL: http://github.com/markdownlint/markdownlint
Licenses: MIT
Submitter: berquist
Maintainer: berquist
Last Packager: berquist
Votes: 1
Popularity: 0.009188
First Submitted: 2017-07-27 13:35
Last Updated: 2018-12-15 16:52

Latest Comments

berquist commented on 2019-02-04 02:26

You're right, I didn't notice it because I have mdl run automatically from flycheck in Emacs, and if one of the checkers isn't working, it automatically gets disabled. I get the same error when trying to run it from the command line

I am not a Rubyist, so I don't know if making versioned packages for the two mixlib gems would even work. I am open to suggestions.

lucc commented on 2019-01-25 09:20

I suspect there is a version conflict between the kramdown that mdl requires and the one in the community repo. I just rebuild the ruby-mdl, ruby-mixlib-cli and ruby-mixlib-config and reinstalled ruby-kramdown from the repos. mdl seems to require kramdown at version 1.12 but neither of the packages in the repo or the aur provides that version.

How do you run mdl and does it work for you?

For completeness here is the exception I get when running mdl:

Traceback (most recent call last):
    8: from /usr/bin/mdl:23:in `<main>'
    7: from /usr/lib/ruby/2.6.0/rubygems.rb:303:in `activate_bin_path'
    6: from /usr/lib/ruby/2.6.0/rubygems.rb:303:in `synchronize'
    5: from /usr/lib/ruby/2.6.0/rubygems.rb:304:in `block in activate_bin_path'
    4: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1420:in `activate'
    3: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `activate_dependencies'
    2: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `each'
    1: from /usr/lib/ruby/2.6.0/rubygems/specification.rb:1449:in `block in activate_dependencies'
/usr/lib/ruby/2.6.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'kramdown' (>= 1.12.0, ~> 1.12) - did find: [kramdown-2.0.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/luc/.gem/ruby/2.6.0:/usr/lib/ruby/gems/2.6.0', execute `gem env` for more information