Package Details: ruby-minitest 5.10.1-1

Git Clone URL: https://aur.archlinux.org/ruby-minitest.git (read-only)
Package Base: ruby-minitest
Description: minitest provides a complete suite of testing facilities supporting TDD, BDD, mocking, and benchmarking
Upstream URL: https://rubygems.org/gems/minitest
Licenses: MIT
Submitter: voyd
Maintainer: voyd
Last Packager: voyd
Votes: 11
Popularity: 1.587036
First Submitted: 2016-08-27 21:58
Last Updated: 2017-01-19 16:42

Latest Comments

ChaosKid42 commented on 2017-03-22 16:16

Your solution works for me. Thanks

voyd commented on 2017-01-19 16:43

Thanks for bringing this to my attention. This error happens because minitest-5.10.1 is bundled with ruby-2.4.0.

I made this package empty so that it can be installed as a dependency until a new minitest version is released.

Please report your experiences with this solution, it seems a bit hackish to me.

ChaosKid42 commented on 2017-01-16 07:17

I get these errors when installing:

error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/History.rdoc'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/Manifest.txt'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/README.rdoc'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/Rakefile'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/design_rationale.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/hoe/minitest.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/assertions.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/autorun.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/benchmark.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/expectations.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/hell.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/mock.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/parallel.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/pride.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/pride_plugin.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/spec.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/test.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/lib/minitest/unit.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/test/minitest/metametameta.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/test/minitest/test_minitest_benchmark.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/test/minitest/test_minitest_mock.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/test/minitest/test_minitest_reporter.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/test/minitest/test_minitest_spec.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/gems/minitest-5.10.1/test/minitest/test_minitest_test.rb'
error: file owned by 'ruby' and 'ruby-minitest': 'usr/lib/ruby/gems/2.4.0/specifications/minitest-5.10.1.gemspec'