Package Details: ruby-msgpack 1.0.0-1

Git Clone URL: https://aur.archlinux.org/ruby-msgpack.git (read-only)
Package Base: ruby-msgpack
Description: MessagePack, a binary-based efficient data interchange format.
Upstream URL: http://msgpack.org/
Licenses: Apache 2.0
Submitter: AlexanderR
Maintainer: skrylar
Last Packager: skrylar
Votes: 76
Popularity: 0.924713
First Submitted: 2012-03-28 06:59
Last Updated: 2016-07-13 21:41

Latest Comments

thestinger commented on 2014-12-06 21:44

Use makepkg -A (--ignorearch) if you're using an architecture that's not officially supported. The packaging guidelines apply to AUR packages and only allow i686 / x86_64 / any:

https://wiki.archlinux.org/index.php/Arch_packaging_standards#Architectures

demaratus commented on 2014-12-06 21:43

please add the armv7h architecture to the PKGBUILD, this package can also build on this architecture

anatolik commented on 2014-02-21 03:08

This package is horribly out-of-date. I would like take ownership and keep improving it. Let me know if you have any objections.

biotin commented on 2013-10-13 22:12

/.rvm/rubies/ruby-2.0.0-p247/lib/ruby/site_ruby/2.0.0/rubygems/specification.rb:1980:in `raise_if_conflicts': can't activate json-1.7.7, already activated json-1.8.0 (Gem::LoadError)

AlexanderR commented on 2012-10-01 21:32

> PKGBUILD require specific version of ruby
It may be the case, but please don't mark package as outdated because of it. This is against the AUR rules.

Anonymous comment on 2012-09-27 21:17

PKGBUILD require specific version of ruby (1.8), 1.9 is in the repos so this doesn't build.

Anonymous comment on 2012-08-28 03:27

this needs rubygems1.8 as a dependency

Anonymous comment on 2012-07-15 02:48

package rubygems doesn't exist anymore; looks like it's been renamed to rubygems1.8

renodesper commented on 2012-04-24 15:08

I get this error now:

makepkg
==> Making package: ruby-msgpack 0.4.6-1 (Tue Apr 24 22:06:34 WIT 2012)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Found msgpack-0.4.6.gem
==> Validating source files with md5sums...
msgpack-0.4.6.gem ... Passed
==> Extracting Sources...
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting package()...
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libfakeroot.so' from LD_PRELOAD cannot be preloaded: ignored.
/home/renodesper/Temporary/ruby-msgpack/PKGBUILD: line 16: 2542 Segmentation fault gem install --ignore-dependencies -i "$pkgdir$_gemdir" -n "$pkgdir/usr/bin" "$_gemname-$pkgver.gem" --no-user-install
==> ERROR: A failure occurred in package().
Aborting...

renodesper commented on 2012-04-24 12:03

I get an error like this:

make install
/bin/mkdir -p /tmp/yaourt-tmp-renodesper/aur-ruby-msgpack/pkg/usr/local/rvm/rubies/ruby-1.9.2-p318/lib/ruby/gems/1.9.1/gems/msgpack-0.4.6/lib
/bin/install -c -m 0755 msgpack.so /tmp/yaourt-tmp-renodesper/aur-ruby-msgpack/pkg/usr/local/rvm/rubies/ruby-1.9.2-p318/lib/ruby/gems/1.9.1/gems/msgpack-0.4.6/lib
make: /bin/install: Command not found
make: *** [/tmp/yaourt-tmp-renodesper/aur-ruby-msgpack/pkg/usr/local/rvm/rubies/ruby-1.9.2-p318/lib/ruby/gems/1.9.1/gems/msgpack-0.4.6/lib/msgpack.so] Error 127