Package Details: ruby-nokogiri 1.6.8-2

Git Clone URL: https://aur.archlinux.org/ruby-nokogiri.git (read-only)
Package Base: ruby-nokogiri
Description: HTML, XML, SAX, and Reader parser
Upstream URL: http://nokogiri.org
Keywords: Gem Ruby
Licenses: MIT
Submitter: None
Maintainer: remy
Last Packager: remy
Votes: 74
Popularity: 2.184296
First Submitted: 2010-03-16 18:47
Last Updated: 2016-09-17 12:25

Latest Comments

remy commented on 2016-09-17 12:25

@all I'm sorry, for some reason I didn't get notifications for the package...
I've added ruby-pkg-config as a makedep, and i'll keep an closer eye on this package.

JohnRobson commented on 2016-09-17 03:50

@skrunc worked, thank you. please add "ruby-pkg-config" as a dependency

axolotl commented on 2016-09-16 20:10

@remy, can you add ruby-pkg-config as a dependency of this package? It is required for build.

skrunc commented on 2016-08-26 17:09

@JohnRobson I have tried it as jmartl109 stated and it worked. Try installing ruby-pkg-config.

JohnRobson commented on 2016-08-22 19:13

==> Validating source files with sha512sums...
nokogiri-1.6.8.gem ... Passed
==> Extracting sources...
==> Entering fakeroot environment...
==> Starting package()...
Building native extensions. This could take a while...
ERROR: Error installing nokogiri-1.6.8.gem:
ERROR: Failed to build gem native extension.

extconf failed, exit code 1

Gem files will remain installed in /tmp/yaourt-tmp-us/aur-ruby-nokogiri/pkg/ruby-nokogiri/usr/lib/ruby/gems/2.3.0/gems/nokogiri-1.6.8 for inspection.
Results logged to /tmp/yaourt-tmp-us/aur-ruby-nokogiri/pkg/ruby-nokogiri/usr/lib/ruby/gems/2.3.0/extensions/x86_64-linux/2.3.0/nokogiri-1.6.8/gem_make.out
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build ruby-nokogiri.

jmartl109 commented on 2016-08-06 01:21

@ArnaudNux You need to install ruby-pkg-config. It should be a dependency (or build dependency?) of this package.

ArnaudNux commented on 2016-08-03 23:23

==> Continue building ruby-nokogiri ? [Y/n]
==> ---------------------------------------
==> y

==> Building and installing package
==> Making package: ruby-nokogiri 1.6.8-1 (Thu Aug 4 01:23:14 CEST 2016)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Downloading nokogiri-1.6.8.gem...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 154 100 154 0 0 154 0 0:00:01 --:--:-- 0:00:01 154
100 8933k 100 8933k 0 0 1283k 0 0:00:06 0:00:06 --:--:-- 1636k
==> Validating source files with sha512sums...
nokogiri-1.6.8.gem ... Passed
==> Extracting sources...
==> Entering fakeroot environment...
==> Starting package()...
Building native extensions. This could take a while...
ERROR: Error installing nokogiri-1.6.8.gem:
ERROR: Failed to build gem native extension.

current directory: /home/arnaud/tempo/yaourt-tmp-arnaud/aur-ruby-nokogiri/pkg/ruby-nokogiri/usr/lib/ruby/gems/2.3.0/gems/nokogiri-1.6.8/ext/nokogiri
/usr/bin/ruby -r ./siteconf20160804-26850-qcw9co.rb extconf.rb
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=/usr/bin/$(RUBY_BASE_NAME)
/usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'pkg-config' (~> 1.1.7) among 13 total gem(s) (Gem::LoadError)
Checked in 'GEM_PATH=/home/arnaud/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information
from /usr/lib/ruby/2.3.0/rubygems/dependency.rb:328:in `to_spec'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:65:in `gem'
from extconf.rb:112:in `<main>'

extconf failed, exit code 1

Gem files will remain installed in /home/arnaud/tempo/yaourt-tmp-arnaud/aur-ruby-nokogiri/pkg/ruby-nokogiri/usr/lib/ruby/gems/2.3.0/gems/nokogiri-1.6.8 for inspection.
Results logged to /home/arnaud/tempo/yaourt-tmp-arnaud/aur-ruby-nokogiri/pkg/ruby-nokogiri/usr/lib/ruby/gems/2.3.0/extensions/x86_64-linux/2.3.0/nokogiri-1.6.8/gem_make.out
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build ruby-nokogiri.
==> Restart building ruby-nokogiri ? [y/N]
==> --------------------------------------

jmartl109 commented on 2016-08-03 20:53

I'm still getting version incompatibility issues with ruby-mini_portile2. Just running

#!/usr/bin/ruby
require 'rubygems'
gem 'nokogiri'

produces

Could not find 'mini_portile2' (~> 2.1.0) - did find: [mini_portile2-2.2.0.rc1] (Gem::LoadError)

But if I edit /usr/lib/ruby/gems/2.3.0/specifications/nokogiri-1.6.8.gemspec and change the mini_portile2 line from "~> 2.1.0" to ">= 2.1.0", it seems to work OK.

dark-saber commented on 2016-08-03 05:40

Thanks for updating!

But this package now depends on ruby-pkg-config too.

dark-saber commented on 2016-06-16 07:35

1.6.8 is out.
Also, nokogiri now depends on ruby-mini_portile2 >= 2.1.0, so I guess these issues with mini_portile are finally solved.

All comments