Package Details: ruby-pdf-reader 2.10.0-1

Git Clone URL: https://aur.archlinux.org/ruby-pdf-reader.git (read-only, click to copy)
Package Base: ruby-pdf-reader
Description: A library for accessing the content of PDF files
Upstream URL: http://github.com/yob/pdf-reader
Licenses: MIT
Submitter: kusakata
Maintainer: dark-saber
Last Packager: dark-saber
Votes: 7
Popularity: 0.004953
First Submitted: 2014-01-16 15:49 (UTC)
Last Updated: 2022-07-20 13:41 (UTC)

Latest Comments

tba commented on 2021-01-29 14:51 (UTC)

Thanks!

dark-saber commented on 2021-01-29 13:46 (UTC)

Hi, updated, thanks, sorry for the very late answer.

tba commented on 2021-01-22 16:33 (UTC)

Hi,

Please update Ascii85 dependency.

depends=(ruby 'ruby-ascii85<1.1' ruby-ruby-rc4 ruby-hashery ruby-ttfunk ruby-afm)

should be sufficient. ruby-ascii85<1.1 is provided by ruby-ascii85-1.0 package.

jthvai commented on 2020-11-24 23:35 (UTC) (edited on 2020-11-25 00:08 (UTC) by jthvai)

I suspect the dependency on ruby-ascii85 needs to be <1.1 (the current AUR package is 1.1.0), per the following output when attempting to use ruby-pdf-reader.

/usr/lib/ruby/2.7.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'Ascii85' (~> 1.0.0) - did find: [Ascii85-1.1.0] (Gem::MissingSpecVersionError)

When pdf-reader is installed via gem alone, Ascii85 1.0.3 is pulled.

Update: I have just tested installing Ascii85 1.0.3 as a dependency instead, and this package now works as intended.