Package Details: ruby-rails 5.0.0.1-1

Git Clone URL: https://aur.archlinux.org/ruby-rails.git (read-only)
Package Base: ruby-rails
Description: Full-stack web application framework.
Upstream URL: http://www.rubyonrails.org
Keywords: gem ruby
Licenses: MIT
Submitter: kidoz
Maintainer: mgrabovsky
Last Packager: mgrabovsky
Votes: 91
Popularity: 0.345199
First Submitted: 2010-05-30 22:48
Last Updated: 2016-08-26 18:41

Latest Comments

Nefas commented on 2016-06-25 16:53

There are missing dependencies :
- mini_portile 0.6 (mini_portile dependency installed with rails is too new)
- rails-dom-testing >= 1.0.5 ~> 1.0
Rails won't work without those packages: every command end with a missing gem error
I know it's easy to install them with `gem install` but this dependencies should be in ruby-rails dependencies.

A1RO commented on 2016-06-07 13:34

To resolve basic gem dependencies for Rails, you could also type the following:
gem install mini_portile -v 0.6.2
gem install rails-dom-testing -v 1.0.7

After this, 'rails --version' and 'rails new project_name' both work fine on my side.

anatolik commented on 2016-05-07 14:02

Try 'ruby-rails' from Quarry repository.

winnie_o0 commented on 2016-05-07 11:17

Dependencies missing/are wrong:
- Mini_portfile version is too new. There's an AUR-Package "ruby-mini_portile0.6" to solve that.
- rails-dom-testing is missing.

Without fixing those, "rails new $projectname" will not succeed.

ewtoombs commented on 2016-03-08 03:45

This package requires the html-sanitizer gem (currently unavailable from the aur) to work. The whole thing is currently broken as a result.

yan12125 commented on 2015-11-14 20:08

Hello @mgrabovsky, can you add --no-ri --no-rdoc due to [1] and [2]?

[1] https://github.com/rails/rails/issues/11814
[2] https://github.com/rdoc/rdoc/issues/361

rumpelsepp commented on 2013-03-14 17:25

3.2.12. is out.
http://weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released/

xyproto commented on 2013-01-11 10:32

Thanks!

kidoz commented on 2013-01-09 17:59

@xyproto
Update

xyproto commented on 2013-01-09 13:44

2.3.15 is out according to this article: http://arstechnica.com/security/2013/01/extremely-crtical-ruby-on-rails-bug-threatens-more-than-200000-sites/

binki commented on 2012-04-16 02:36

I get an error like “Could not find builder (~> 3.0.0) amongst […builder-2.1.2, …]” when trying to use this package to run a rails application. I think ruby-rails aur package should depend on >=ruby-builder-3.0.0. ruby-rails-aio appears to include that package, so why not the dep here?

solstice commented on 2012-03-16 19:03

Please remove that horrible 'Is' at the beggining of the pkgdesc

cgirard commented on 2012-02-29 20:04

That was quick. Thx.

kidoz commented on 2012-02-29 20:01

Fix

cgirard commented on 2012-02-29 19:51

actionpack has runtime dependency: sprockets ~> 2.1.2
You provide 2.3.0 which is too new.

kidoz commented on 2012-01-22 12:22

@eagletmt
Done.

eagletmt commented on 2012-01-17 05:21

Please provide with pkgver like this: provides=("ruby-actionmailer=${_actionmailer_pkgver}" ...)

slopjong commented on 2012-01-07 13:45

Installation failed because of: "No such file or directory - /tmp/yaourt-tmp/aur-rails/pkg/usr/bin"

I'm using rubygems 1.3.7, the lowest version that redmine requires.

slopjong commented on 2012-01-07 13:39

Installation failed because of: "No such file or directory - /tmp/yaourt-tmp/aur-rails/pkg/usr/bin"

I'm using rubygems 1.3.7

td123 commented on 2011-08-17 02:46

http://www.ruby-forum.com/topic/2373312
3.0.10 is out

kidoz commented on 2010-10-28 10:38

Created for 3.0.1 - ruby-rails-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-03 04:42

Created for 3.0.0 - ruby-rails, with dependencies.
Created for 2.3.8 - ruby-rails2xx, with dependencies.
Created for 3.0.0 - ruby-rails-aio, self-contained for quick and easy installation
Created for 2.3.8 - ruby-rails2xx-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-03 04:37

For simple and fast install.

kidoz commented on 2010-09-03 04:35

reated for 3.0.0 - ruby-rails-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-03 04:01

Created for 2.3.8 - ruby-rails2xx-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-02 21:45

Created for 2.3.8 - ruby-rails2xx, also corrected all the dependencies.
All advise to use ruby-rails2xx.
The dependence of the ruby-sqlite3 do?

kidoz commented on 2010-09-01 20:17

Update to 3.0?

kidoz commented on 2010-05-30 23:24

Tested.