Package Details: ruby-ruby_dep 1.5.0-4

Git Clone URL: https://aur.archlinux.org/ruby-ruby_dep.git (read-only)
Package Base: ruby-ruby_dep
Description: Automatically helps determine supported Rubies based on .travis.yml file
Upstream URL: https://github.com/e2/ruby_dep
Keywords: ruby
Licenses: MIT
Submitter: patrick.luehne
Maintainer: patrick.luehne
Last Packager: patrick.luehne
Votes: 4
Popularity: 0.090927
First Submitted: 2017-10-23 22:00
Last Updated: 2018-08-23 17:02

Dependencies (3)

Required by (2)

Sources (1)

Latest Comments

patrick.luehne commented on 2018-08-23 17:02

@alex.shpilkin: Thanks for letting me know about the missing make dependency!

alex.shpilkin commented on 2018-07-13 07:07

@patrick.luehne rdoc used to be included in the ruby package, but no longer is, so this package will no longer build unless you add a makedepend on ruby-rdoc. (You can try building it within a chroot to confirm.)

robbystk commented on 2018-05-30 04:20

Sorry for the lack of prompt response. All I know is that I get the following error when running makepkg during the build() stage:

ERROR:  While executing gem ... (Gem::DocumentError)
    RDoc is not installed: cannot load such file -- rdoc/rdoc
==> ERROR: A failure occurred in package().
    Aborting...

patrick.luehne commented on 2018-04-06 22:18

@robbystk: Can you please elaborate? ruby-rdoc is not listed in the gemspec [1] and I can’t find a mention of ruby-rdoc elsewhere.

[1] https://github.com/e2/ruby_dep/blob/master/ruby_dep.gemspec

robbystk commented on 2018-04-06 22:15

Depends on ruby-rdoc as well.