Package Details: ruby-rugged 0.26.0-1

Git Clone URL: https://aur.archlinux.org/ruby-rugged.git (read-only)
Package Base: ruby-rugged
Description: Rugged is a Ruby binding to the libgit2 linkable library
Upstream URL: https://github.com/libgit2/rugged
Licenses: MIT
Submitter: atweiden
Maintainer: None
Last Packager: ChaosKid42
Votes: 3
Popularity: 0.000000
First Submitted: 2015-05-07 23:05
Last Updated: 2017-08-31 12:18

Latest Comments

paulsinnett commented on 2018-06-09 17:41

Here's a patch:

The following changes since commit 72b8c06db583:

updated to v0.26.0 (2017-08-31 14:17:39 +0200)

are available in the Git repository at:

https://github.com/paulsinnett/ruby-rugged.git

for you to fetch changes up to d97fca504862660ff87c6397d5238b078a7e488e:

upgrade to 27 (2018-06-09 18:28:08 +0100)

<hr>

Paul Sinnett (1): upgrade to 27

.SRCINFO | 11 +++++------ PKGBUILD | 6 +++--- 2 files changed, 8 insertions(+), 9 deletions(-)

paulsinnett commented on 2018-05-19 17:36

Now refuses to build against libgit2-1:0.27.0-1.

Building Rugged using system libraries.
libgit2 version is not compatible, expected ~> 0.26.0
*** extconf.rb failed ***

ChaosKid42 commented on 2017-08-31 12:18

Should be fixed now after updating to 0.26.0

qwattash commented on 2017-08-05 23:22

Refuses to build against libgit2 1:0.26.0-1, it seems to require 0.25 only.

Building Rugged using system libraries.
libgit2 version is not compatible, expected ~> 0.25.0
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.

I can provide the mkmf.log and other output if required.

drwho commented on 2017-05-01 03:52

Refuses to build against libgit2 1:0.25.1-2. Throws the following error in the build log:

"gcc -I/usr/include/ruby-2.4.0/x86_64-linux -I/usr/include/ruby-2.4.0/ruby/backward -I/usr/include/ruby-2.4.0 -I. -D_FORTIFY_SOURCE=2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fPIC -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -g -Wall -Wno-comment -c conftest.c"
conftest.c:6:2: error: #error libgit2 version is not compatible
#error libgit2 version is not compatible
^~~~~
checked program was:
/* begin */
1: #include "ruby.h"
2:
3: #include <git2/version.h>
4:
5: #if LIBGIT2_VER_MAJOR != 0 || LIBGIT2_VER_MINOR != 24
6: #error libgit2 version is not compatible
7: #endif
/* end */

It seems to demand libgit2 v0.24 only, which isn't available in the Arch package repos anymore. Maybe a patch is needed?

Anonymous comment on 2016-01-05 08:40

Has a makedepend on cmake