Package Details: ruby-rugged 0.26.0-1

Git Clone URL: (read-only)
Package Base: ruby-rugged
Description: Rugged is a Ruby binding to the libgit2 linkable library
Upstream URL:
Licenses: MIT
Submitter: atweiden
Maintainer: None
Last Packager: ChaosKid42
Votes: 3
Popularity: 0.000017
First Submitted: 2015-05-07 23:05
Last Updated: 2017-08-31 12:18

Latest Comments

ChaosKid42 commented on 2017-08-31 12:18

Should be fixed now after updating to 0.26.0

qwattash commented on 2017-08-05 23:22

Refuses to build against libgit2 1:0.26.0-1, it seems to require 0.25 only.

Building Rugged using system libraries.
libgit2 version is not compatible, expected ~> 0.25.0
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.

I can provide the mkmf.log and other output if required.

drwho commented on 2017-05-01 03:52

Refuses to build against libgit2 1:0.25.1-2. Throws the following error in the build log:

"gcc -I/usr/include/ruby-2.4.0/x86_64-linux -I/usr/include/ruby-2.4.0/ruby/backward -I/usr/include/ruby-2.4.0 -I. -D_FORTIFY_SOURCE=2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fPIC -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -g -Wall -Wno-comment -c conftest.c"
conftest.c:6:2: error: #error libgit2 version is not compatible
#error libgit2 version is not compatible
checked program was:
/* begin */
1: #include "ruby.h"
3: #include <git2/version.h>
5: #if LIBGIT2_VER_MAJOR != 0 || LIBGIT2_VER_MINOR != 24
6: #error libgit2 version is not compatible
7: #endif
/* end */

It seems to demand libgit2 v0.24 only, which isn't available in the Arch package repos anymore. Maybe a patch is needed?

Anonymous comment on 2016-01-05 08:40

Has a makedepend on cmake