Package Details: ruby-sequel 4.36.0-1

Git Clone URL: https://aur.archlinux.org/ruby-sequel.git (read-only)
Package Base: ruby-sequel
Description: The Database Toolkit for Ruby
Upstream URL: http://sequel.jeremyevans.net
Licenses: MIT
Conflicts: sequel
Provides: ruby-sequel, sequel
Submitter: ImNtReal
Maintainer: None
Last Packager: atweiden
Votes: 3
Popularity: 0.000000
First Submitted: 2012-01-18 20:17
Last Updated: 2016-07-01 15:02

Dependencies (2)

Required by (1)

Sources (1)

Latest Comments

ImNtReal commented on 2013-06-25 15:14

I can't explain why, but it seems to be setting the pkgdir with no permissions. I don't actually use this anymore, so I'm going to orphan it.

Anonymous comment on 2013-06-25 11:55

Was not able to build with the current PKGBUILD. Somehow the license download made problems. Additionally I stole a line from another gem (not that I had any idea what i'm doing) and edited the gem install line.
`
# Contributor: Jameson Pugh <imntreal@gmail.com>
# Maintainer: Jameson Pugh <imntreal@gmail.com>

pkgname=ruby-sequel
_gemname=sequel
pkgver=3.31.0
pkgrel=1
pkgdesc="Sequel database toolkit for Ruby"
arch=('any')
url="http://sequel.rubyforge.org/"
license=('MIT')
depends=('ruby')
makedepends=('rubygems')
source=("http://rubygems.org/downloads/sequel-$pkgver.gem")
noextract=(${_gemname}-${pkgver}.gem)
md5sums=('98f35410849e6778a6b6bce1fcf28697')

build() {
cd "${srcdir}"
local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
gem install --no-user-install --ignore-dependencies --verbose -i "${pkgdir}${_gemdir}" -n "${pkgdir}"/usr/bin sequel-${pkgver}.gem
}
`