Package Details: ruby-svn 40220-1

Git Clone URL: (read-only)
Package Base: ruby-svn
Description: A dynamic, open source programming language with a focus on simplicity and productivity.
Upstream URL:
Licenses: custom, BSD
Submitter: None
Maintainer: None
Last Packager: JonnyJD
Votes: 10
Popularity: 0.000000
First Submitted: 2007-01-09 12:49
Last Updated: 2015-06-15 13:28

Latest Comments

JonnyJD commented on 2016-03-09 06:28

Hm, currently not using the package. You want to maintain? (disowned)

Synthead commented on 2016-03-09 04:44

Made this from the upstream ruby PKGBUILD:

Feel free to use it as you'd like.

Synthead commented on 2016-03-09 04:10

@ipickering: I'm getting that too, yeah.

ipickering commented on 2016-01-30 19:32

Does anyone else get these errors when installing?

cp: cannot create regular file ‘/home/ruin/build/ruby-svn/ruby-svn/src/ruby/.svn/pristine/76/766ed7eca3d67e4a82a96757e016fb83720a24e9.svn-base’: Permission denied
cp: cannot create regular file ‘/home/ruin/build/ruby-svn/ruby-svn/src/ruby/.svn/pristine/76/762d786ec8008a7ef61b7558650852ed3de8eca2.svn-base’: Permission denied
cp: cannot create regular file ‘/home/ruin/build/ruby-svn/ruby-svn/src/ruby/.svn/pristine/76/76c1d341d31e3106c134f7acc9f17c881a45c877.svn-base’: Permission denied
(repeated many times)

JonnyJD commented on 2013-04-10 22:19

Updated for pacman 4.1 (different svn package handling) and added check().
I commented the "make install-docs" out. Uncomment if you need it.
(50 vs 250 MB)

check() is disabled by default.
Currently (revision 40217) I had these problems:
An error for test 1957 (test_make_socket_ipv6_multicast(Rinda::TestRingServer))
and test 7190 is skipped (test_capture_subprocess_io, "Dunno why but the parallel run of this fails")

Current version name is 2.1.0dev.

JonnyJD commented on 2013-01-28 17:23

FYI: This package is now in

JonnyJD commented on 2010-04-01 10:52

set or reset the pkgver in the PKGBUILD and do

makepkg --holdver

This will keep makepkg from automatically fetching the newest revision.

Wintershade commented on 2010-04-01 10:22

sorry for the n00b question, but how exactly do I choose the svn revision which I want to compile? I'm reading the documentation, but I can't make anything useful out of it... TIA

JonnyJD commented on 2010-03-29 10:59

This is the reason one has to use this unstable svn trunk:

There is no backport yet for 1.9.1 and I couldn't find out which revision does the actual fix.

JonnyJD commented on 2010-03-29 10:27

Well somewhere in the comments that got lost (see there was a list of working revisions.
This is real production code, not a stable trunk. 26652 works though and is necessary for a bugfix of (rubyripper)

note: in my experience there are actually a lot more failing revisions than working ones. When somebody gets later revisions working, please tell in the comments. Thanks.

All comments