Package Details: ruby-travis 1.11.1-1

Git Clone URL: (read-only, click to copy)
Package Base: ruby-travis
Description: CLI and Ruby client library for Travis CI
Upstream URL:
Licenses: MIT
Submitter: joschi
Maintainer: DDoSolitary (lilac)
Last Packager: lilac
Votes: 18
Popularity: 0.000000
First Submitted: 2013-01-27 12:49 (UTC)
Last Updated: 2022-06-09 13:37 (UTC)

Latest Comments

DDoSolitary commented on 2021-03-01 04:39 (UTC)

@bartus No, I won't fix other broken packages here. You can manually install the missing dependencies as a temporary fix.

bartus commented on 2021-02-27 09:42 (UTC)

@DDoSolitary: could we add ruby-faraday-net_http for the time being, at least until community/ruby-faraday gets fixed...

DDoSolitary commented on 2020-12-21 14:22 (UTC)

@davvore33 It seems that community/ruby-faraday, which this package depends on, is broken due to lack of a dependency. I'm going to report this problem there.

davvore33 commented on 2020-12-21 13:57 (UTC) (edited on 2020-12-21 13:58 (UTC) by davvore33)

Hi, I've got a similar dep issue

travis --help                                                                                                                                                                                                      125 
Traceback (most recent call last):
        12: from /usr/bin/travis:23:in `<main>'
        11: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
        10: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
         9: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
         8: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         7: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         6: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         5: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1403:in `block in activate_dependencies'
         4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'ruby2_keywords' (>= 0) among 76 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/matteo/.gem/ruby/2.7.0:/usr/lib/ruby/gems/2.7.0', execute `gem env` for more information

DDoSolitary commented on 2020-09-09 15:38 (UTC)

@replabrobin It seems that upstream restricted launchy version to < 2.5.0 for compatibility with Ruby 2.3. I just removed that restriction. Please check if it works now.

replabrobin commented on 2020-09-07 11:40 (UTC)

I get some kind of dependency problem after install today

$ travis --help
Traceback (most recent call last):
    8: from /bin/travis:23:in `<main>'
    7: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
    6: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
    5: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
    4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
    3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
    2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
    1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'launchy' (~> 2.1, < 2.5.0) - did find: [launchy-2.5.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/robin/.gem/ruby/2.7.0:/usr/lib/ruby/gems/2.7.0', execute `gem env` for more information

DDoSolitary commented on 2020-05-08 04:38 (UTC)

@J5lx Fixed.

DDoSolitary commented on 2020-05-08 03:13 (UTC)

@J5lx It seems that the missing dependency issues are actually from the ruby-gh package. I will update there.

J5lx commented on 2020-05-07 18:16 (UTC) (edited on 2020-05-07 18:17 (UTC) by J5lx)

Please add ruby-activesupport and ruby-minitest to the dependencies, without those packages running travis fails. Additionally, without ruby-pry the zsh shell completion displays an error.

DDoSolitary commented on 2020-04-15 16:24 (UTC) (edited on 2020-04-15 16:25 (UTC) by DDoSolitary)

Upstream just added a commit that brings compatibility with version 1.0 of ruby-faraday and ruby-faraday-middleware:

So I decide not to fix the dependencies here but wait a few days until they have the changed released.

DDoSolitary commented on 2020-04-06 10:49 (UTC)

It seems that faraday_middleware has been updated to a version incompatible with ruby-travis as well. I will try to fix it by creating separate package for version 0.9 of faraday_middleware when I can find some spare time.

mafzst commented on 2020-04-06 10:42 (UTC)

I encounter the same problem as @bartus with faraday_middleware. As this package isn't available with version 0.9.1 in AUR, I've made a patch to you PKGBUILD here

All went well for me except some warning during execution about deprecated calls.

DDoSolitary commented on 2020-03-08 11:22 (UTC)

@bartus Fixed.

bartus commented on 2020-01-17 21:13 (UTC)

@DDoSolitary: since [community]/ruby-faraday was updated to 1.0.0 it's no longer viable for ruby-travis.

DDoSolitary commented on 2019-10-24 20:59 (UTC)

By the way, I'm considering disowning this package because I no longer use Travis and thus this package anymore.

DDoSolitary commented on 2019-10-24 20:57 (UTC)

Sorry, I didn't realize that AUR helpers can't handle such dependencies directly because I myself use a special script to build the packages I use. I've fixed the dependancis and the package should be build-able now.

4O4 commented on 2019-10-07 17:06 (UTC)

@DDoSolitary I can't uninstall what I don't have yet ;) I tried the command anyway despite knowing it won't be able to help unless it employs some kind of magic and yeah it obviously failed. The problem is with fresh install and it's because of changes in these dependencies. Search for typhoeus and highline on AUR and you will see that there are separate packages for separate versions for some reasons (probably compatibility) and current version-bound dependencies can never be resolved anymore.

DDoSolitary commented on 2019-10-07 13:43 (UTC)

@4O4 @bartus @unkcpz Please read the pinned comment first. Let me know if you still experience problems after you uninstall&reinstall this package.

4O4 commented on 2019-10-07 10:44 (UTC) (edited on 2019-10-07 10:44 (UTC) by 4O4)

Couldn't install because highline and typhoeus dependencies can't be resolved due to some repo reorganization probably. It works after modifying depends like that: depends=(ruby ruby-backports ruby-faraday ruby-faraday-middleware ruby-gh ruby-highline-1.6 ruby-launchy ruby-pusher-client ruby-typhoeus-0.6)

bartus commented on 2019-05-30 08:20 (UTC) (edited on 2019-05-31 15:00 (UTC) by bartus)

@DDoSolitary: aur helper can't resolve dependency version defined in PKGUBILD:provide=($pkgname=$pkgver). I've checked aurutils, aurman, auracle, pacaur without any luck (aurutils with aur-graph can alert user about version missmache but won't find correct one`).

Consider updating depends array to point specifically to aur packages providing correct version of ruty-(highline|typhyeus) ...

unkcpz commented on 2019-05-30 07:17 (UTC)

:: Package ruby-travis not found in repositories, trying AUR... :: resolving dependencies... :: no results found for ruby-highline<2.0.0 (dependency tree: ruby-travis ruby-highline) :: no results found for ruby-typhoeus<1.0.0 (dependency tree: ruby-travis ruby-typhoeus)

hendry commented on 2019-01-21 07:40 (UTC)

Any ideas about:

[hendry@t480s invite]$ travis env list Traceback (most recent call last): 2: from /usr/bin/travis:23:in <main>' 1: from /usr/lib/ruby/2.6.0/rubygems.rb:302:inactivate_bin_path' /usr/lib/ruby/2.6.0/rubygems.rb:283:in `find_spec_for_exe': can't find gem travis (>= 0.a) with executable travis (Gem::GemNotFoundException)

Re-install didn't help.

DDoSolitary commented on 2018-08-25 02:31 (UTC)

If you have problem upgrading ruby-highline, please run "pacman -Rns ruby-travis" to uninstall this package and its dependencies and then install ruby-travis again with your favorite AUR helper. Then pacman should be able to correctly install ruby-highline-1.6.

DDoSolitary commented on 2018-08-24 09:35 (UTC)

@02m Please try uninstalling ruby-highline and installing ruby-highline-1.6

02m commented on 2018-08-24 06:26 (UTC)

I was unable to upgrade to the latest package version because of:

error: failed to prepare transaction (could not satisfy dependencies) :: installing ruby-highline (2.0.0-1) breaks dependency 'ruby-highline<2.0.0' required by ruby-travis

DDoSolitary commented on 2018-08-23 02:25 (UTC)

@iboyperson It's a dependency issue of ruby-gh and I just fixed it.

tjquillan commented on 2018-08-22 04:51 (UTC) (edited on 2018-08-22 04:51 (UTC) by tjquillan)

Travis is crashing with this error even though I have addressable installed:

$ travis
Traceback (most recent call last): 12: from /usr/bin/travis:23:in <main>' 11: from /usr/lib/ruby/2.5.0/rubygems.rb:309:inactivate_bin_path' 10: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in synchronize' 9: from /usr/lib/ruby/2.5.0/rubygems.rb:310:inblock in activate_bin_path' 8: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1443:in activate' 7: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:inactivate_dependencies' 6: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in each' 5: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1475:inblock in activate_dependencies' 4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1443:in activate' 3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:inactivate_dependencies' 2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in each' 1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1472:inblock in activate_dependencies' /usr/lib/ruby/2.5.0/rubygems/dependency.rb:313:in to_specs': Could not find 'addressable' (~> 2.4.0) - did find: [addressable-2.5.2] (Gem::MissingSpecVersionError) Checked in 'GEM_PATH=/home/iboyperson/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', executegem env` for more information

Svenstaro commented on 2018-05-16 14:54 (UTC)

Hey @CarstenF can you fix those deps and add ruby-connection_pool as suggested?

02m commented on 2018-03-28 06:55 (UTC)

Just a note that a dependency to ruby-connection_pool is still missing. I had to install it manually.

loathingkernel commented on 2018-03-23 09:04 (UTC)

@ebiadsu, I added the package just for this reason, if @CarstenF wants to adopt it, I can disown it.

ebiadsu commented on 2018-03-23 02:14 (UTC)

Adding aur package ruby-connection_pool ( as dependency should fix this issue in my opinion.

Darkhogg commented on 2018-02-27 13:38 (UTC)

This package is mising the connection_pool gem as a dependency. As of now it's not available on the AUR, I installed it with pacgem (pacgem connection_pool) and travis now works perfectly.

commented on 2018-02-15 19:43 (UTC)

$ travis -h
Traceback (most recent call last):
    16: from /usr/bin/travis:23:in `<main>'
    15: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `activate_bin_path'
    14: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `synchronize'
    13: from /usr/lib/ruby/2.5.0/rubygems.rb:310:in `block in activate_bin_path'
    12: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in `activate'
    11: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `activate_dependencies'
    10: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `each'
     9: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1471:in `block in activate_dependencies'
     8: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in `activate'
     7: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `activate_dependencies'
     6: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `each'
     5: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1471:in `block in activate_dependencies'
     4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in `activate'
     3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `activate_dependencies'
     2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `each'
     1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1468:in `block in activate_dependencies'
/usr/lib/ruby/2.5.0/rubygems/dependency.rb:310:in `to_specs': Could not find 'connection_pool' (~> 2.2) among 40 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/magnus/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', execute `gem env` for more information

B_E commented on 2018-02-06 13:53 (UTC)

ruby-rdoc appears to be a missing dependency:

Successfully installed backports-3.6.7 ERROR: While executing gem ... (Gem::DocumentError) RDoc is not installed: cannot load such file -- rdoc/rdoc

DDoSolitary commented on 2017-10-23 11:58 (UTC) (edited on 2018-01-13 07:38 (UTC) by DDoSolitary)

There is a "ruby-faraday-middleware" in the Community repo. Could you please replace "ruby-faraday_middleware" with it?

nmiculinic commented on 2017-09-12 10:09 (UTC)

Got following error: /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:120:in `require': cannot load such file -- travis/client/cache (LoadError) from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:120:in `require' from /home/lpp/.gem/ruby/2.4.0/gems/travis-1.8.8/lib/travis/client.rb:16:in `<top (required)>' from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require' from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require' from /home/lpp/.gem/ruby/2.4.0/gems/travis-1.8.8/lib/travis/cli.rb:2:in `<top (required)>' from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require' from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require' from /home/lpp/.gem/ruby/2.4.0/gems/travis-1.8.8/bin/travis:7:in `<top (required)>' from /usr/bin/travis:22:in `load' from /usr/bin/travis:22:in `<main>'

Swizz commented on 2017-05-09 09:32 (UTC)

Got the following warning : " Ignoring rainbow-2.2.1 because its extensions are not built. Try: gem pristine rainbow --version 2.2.1" Any way to add 'gem pristine rainbow --version 2.2.1' in the build process ?

CarstenF commented on 2017-03-22 20:28 (UTC)

@mildred: I have removed the dependency ranges from the dependecys. Now the dependecy installation should work.

mildred commented on 2017-03-22 09:25 (UTC)

There are many missing dependencies that I had to install manually (probably because the required version had changed): ruby-faraday ruby-multipart-post ruby-faraday-middleware ruby-highline ruby-backports ruby-gh ruby-multi_json ruby-addressable ruby-net-http-persistent ruby-net-http-pipeline ruby-launchy ruby-ethon ruby-ffi ruby-pusher-client ruby-websocket

jonnor commented on 2016-12-12 18:12 (UTC)

ruby-travis 1.8.5 is out. However, it is not compatible with latest versions of the dependecies available in AUR. I needed to: * Update ruby-faraday_middleware 0.10.1 (was 0.10.0, has been flagged-out-of date) * Downgrade ruby-typhoeus to 0.6.8 (was 0.10.x, no ruby-typhoeus-0.6 package exists right now)

siddharthist commented on 2016-06-20 09:57 (UTC)

I'm getting the following error, looks like a missing dependency: /usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'typhoeus' (>= 0.6.8, ~> 0.6) - did find: [typhoeus-1.0.2] (Gem::LoadError) Checked in 'GEM_PATH=/home/siddharthist/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1438:in `block in activate_dependencies' from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `each' from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `activate_dependencies' from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1409:in `activate' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:68:in `block in gem' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `synchronize' from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `gem' from /usr/bin/travis:22:in `<main>'

carstene1ns commented on 2015-09-28 08:51 (UTC)

jantman: The package is orphaned, so you can easily update it yourself. Btw. the latest version is also available in quarry repository:

jantman commented on 2015-09-27 22:04 (UTC)

version 1.8.0 was released on July 15 2015

joschi commented on 2014-03-16 09:55 (UTC)

Ok, it seems that ruby-ethon ( is the "offender". @LordAro: You can install a fixed version of ruby-ethon (which depends on ruby-mime-types-1) from or you can wait until the package has been updated on AUR.

joschi commented on 2014-03-16 09:43 (UTC)

@LordAro: Thanks for the feedback! Unfortunately ruby-mime-types ( is a dependency of another package and there's not much I can do about a broken dependency. The dependency in question should probably depend on ruby-mime-types-1 ( instead.

LordAro commented on 2014-03-16 09:26 (UTC)

fresh install, i'm getting: [lordaro@Donald ~]$ travis /usr/lib/ruby/2.1.0/rubygems/dependency.rb:298:in `to_specs': Could not find 'mime-types' (~> 1.18) - did find: [mime-types-2.2] (Gem::LoadError) from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1295:in `block in activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1298:in `block in activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `each' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1284:in `activate_dependencies' from /usr/lib/ruby/2.1.0/rubygems/specification.rb:1266:in `activate' from /usr/lib/ruby/2.1.0/rubygems/core_ext/kernel_gem.rb:54:in `gem' from /usr/bin/travis:22:in `<main>'

Freso commented on 2013-10-24 22:58 (UTC)

Yep, works now. Cheers. :)

joschi commented on 2013-10-24 21:43 (UTC)

@Fresco: I've just updated the package to travis 1.5.8. Please check if your problem has been solved with the new package.

Freso commented on 2013-10-24 21:32 (UTC)

I get the following when I try to run `travis` right after install: