Package Details: ruby-travis 1.8.8-1

Git Clone URL: (read-only)
Package Base: ruby-travis
Description: CLI and Ruby client library for Travis CI
Upstream URL:
Licenses: MIT
Submitter: joschi
Maintainer: CarstenF
Last Packager: CarstenF
Votes: 13
Popularity: 0.549300
First Submitted: 2013-01-27 12:49
Last Updated: 2017-03-22 20:25

Latest Comments

DDoSolitary commented on 2017-10-23 11:58

There is a "ruby-faraday-middleware" in the Community repo. Could you please replace "ruby-faraday_middleware" with it?

nmiculinic commented on 2017-09-12 10:09

Got following error:

/usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:120:in `require': cannot load such file -- travis/client/cache (LoadError)
from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:120:in `require'
from /home/lpp/.gem/ruby/2.4.0/gems/travis-1.8.8/lib/travis/client.rb:16:in `<top (required)>'
from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
from /home/lpp/.gem/ruby/2.4.0/gems/travis-1.8.8/lib/travis/cli.rb:2:in `<top (required)>'
from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
from /usr/lib/ruby/2.4.0/rubygems/core_ext/kernel_require.rb:68:in `require'
from /home/lpp/.gem/ruby/2.4.0/gems/travis-1.8.8/bin/travis:7:in `<top (required)>'
from /usr/bin/travis:22:in `load'
from /usr/bin/travis:22:in `<main>'

Swizz commented on 2017-05-09 09:32

Got the following warning :
" Ignoring rainbow-2.2.1 because its extensions are not built.
Try: gem pristine rainbow --version 2.2.1"

Any way to add 'gem pristine rainbow --version 2.2.1' in the build process ?

CarstenF commented on 2017-03-22 20:28

@mildred: I have removed the dependency ranges from the dependecys. Now the dependecy installation should work.

mildred commented on 2017-03-22 09:25

There are many missing dependencies that I had to install manually (probably because the required version had changed): ruby-faraday ruby-multipart-post ruby-faraday-middleware ruby-highline ruby-backports ruby-gh ruby-multi_json ruby-addressable ruby-net-http-persistent ruby-net-http-pipeline ruby-launchy ruby-ethon ruby-ffi ruby-pusher-client ruby-websocket

jonnor commented on 2016-12-12 18:12

ruby-travis 1.8.5 is out. However, it is not compatible with latest versions of the dependecies available in AUR. I needed to:
* Update ruby-faraday_middleware 0.10.1 (was 0.10.0, has been flagged-out-of date)
* Downgrade ruby-typhoeus to 0.6.8 (was 0.10.x, no ruby-typhoeus-0.6 package exists right now)

siddharthist commented on 2016-06-20 09:57

I'm getting the following error, looks like a missing dependency:

/usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'typhoeus' (>= 0.6.8, ~> 0.6) - did find: [typhoeus-1.0.2] (Gem::LoadError)
Checked in 'GEM_PATH=/home/siddharthist/.gem/ruby/2.3.0:/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1438:in `block in activate_dependencies'
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `each'
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1427:in `activate_dependencies'
from /usr/lib/ruby/2.3.0/rubygems/specification.rb:1409:in `activate'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:68:in `block in gem'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `synchronize'
from /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:67:in `gem'
from /usr/bin/travis:22:in `<main>'

carstene1ns commented on 2015-09-28 08:51

jantman: The package is orphaned, so you can easily update it yourself.
Btw. the latest version is also available in quarry repository:

jantman commented on 2015-09-27 22:04

version 1.8.0 was released on July 15 2015

joschi commented on 2014-03-16 09:55

Ok, it seems that ruby-ethon ( is the "offender".

@LordAro: You can install a fixed version of ruby-ethon (which depends on ruby-mime-types-1) from or you can wait until the package has been updated on AUR.

All comments