Package Details: ruby-travis 1.8.10-1

Git Clone URL: https://aur.archlinux.org/ruby-travis.git (read-only)
Package Base: ruby-travis
Description: CLI and Ruby client library for Travis CI
Upstream URL: https://github.com/travis-ci/travis.rb
Licenses: MIT
Submitter: joschi
Maintainer: DDoSolitary
Last Packager: DDoSolitary
Votes: 17
Popularity: 0.311953
First Submitted: 2013-01-27 12:49
Last Updated: 2019-05-08 12:27

Pinned Comments

DDoSolitary commented on 2018-08-25 02:31

If you have problem upgrading ruby-highline, please run "pacman -Rns ruby-travis" to uninstall this package and its dependencies and then install ruby-travis again with your favorite AUR helper. Then pacman should be able to correctly install ruby-highline-1.6.

Latest Comments

1 2 3 Next › Last »

bartus commented on 2019-05-30 08:20

@DDoSolitary: aur helper can't resolve dependency version defined in PKGUBILD:provide=($pkgname=$pkgver). I've checked aurutils, aurman, auracle, pacaur without any luck (aurutils with aur-graph can alert user about version missmache but won't find correct one`).

Consider updating depends array to point specifically to aur packages providing correct version of ruty-(highline|typhyeus) ...

unkcpz commented on 2019-05-30 07:17

:: Package ruby-travis not found in repositories, trying AUR... :: resolving dependencies... :: no results found for ruby-highline<2.0.0 (dependency tree: ruby-travis ruby-highline) :: no results found for ruby-typhoeus<1.0.0 (dependency tree: ruby-travis ruby-typhoeus)

hendry commented on 2019-01-21 07:40

Any ideas about:

[hendry@t480s invite]$ travis env list Traceback (most recent call last): 2: from /usr/bin/travis:23:in <main>' 1: from /usr/lib/ruby/2.6.0/rubygems.rb:302:inactivate_bin_path' /usr/lib/ruby/2.6.0/rubygems.rb:283:in `find_spec_for_exe': can't find gem travis (>= 0.a) with executable travis (Gem::GemNotFoundException)

Re-install didn't help.

DDoSolitary commented on 2018-08-25 02:31

If you have problem upgrading ruby-highline, please run "pacman -Rns ruby-travis" to uninstall this package and its dependencies and then install ruby-travis again with your favorite AUR helper. Then pacman should be able to correctly install ruby-highline-1.6.

DDoSolitary commented on 2018-08-24 09:35

@02m Please try uninstalling ruby-highline and installing ruby-highline-1.6

02m commented on 2018-08-24 06:26

I was unable to upgrade to the latest package version because of:

error: failed to prepare transaction (could not satisfy dependencies) :: installing ruby-highline (2.0.0-1) breaks dependency 'ruby-highline<2.0.0' required by ruby-travis

DDoSolitary commented on 2018-08-23 02:25

@iboyperson It's a dependency issue of ruby-gh and I just fixed it.

iboyperson commented on 2018-08-22 04:51

Travis is crashing with this error even though I have addressable installed:

$ travis
Traceback (most recent call last): 12: from /usr/bin/travis:23:in <main>' 11: from /usr/lib/ruby/2.5.0/rubygems.rb:309:inactivate_bin_path' 10: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in synchronize' 9: from /usr/lib/ruby/2.5.0/rubygems.rb:310:inblock in activate_bin_path' 8: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1443:in activate' 7: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:inactivate_dependencies' 6: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in each' 5: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1475:inblock in activate_dependencies' 4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1443:in activate' 3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:inactivate_dependencies' 2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1461:in each' 1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1472:inblock in activate_dependencies' /usr/lib/ruby/2.5.0/rubygems/dependency.rb:313:in to_specs': Could not find 'addressable' (~> 2.4.0) - did find: [addressable-2.5.2] (Gem::MissingSpecVersionError) Checked in 'GEM_PATH=/home/iboyperson/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', executegem env` for more information

Svenstaro commented on 2018-05-16 14:54

Hey @CarstenF can you fix those deps and add ruby-connection_pool as suggested?

02m commented on 2018-03-28 06:55

Just a note that a dependency to ruby-connection_pool is still missing. I had to install it manually.