Package Details: ruby-xapian-full 1.2.3-1

Git Clone URL: https://aur.archlinux.org/ruby-xapian-full.git (read-only, click to copy)
Package Base: ruby-xapian-full
Description: xapian-core + Ruby xapian-bindings
Upstream URL: https://rubygems.org/gems/xapian-full
Submitter: None
Maintainer: None
Last Packager: vorot93
Votes: 11
Popularity: 0.000000
First Submitted: 2010-03-09 04:44
Last Updated: 2015-06-14 02:16

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2

Anonymous comment on 2011-04-25 09:30

I have strange error with this package (dependency for sup). It seems to use some option which is not recognized by "gcc". Below output is from the run over yaourt, but it behaves the same with "makepkg" only.
(I have pacman 3.5.2-1)

configure:3866: checking whether the C compiler works
configure:3888: gcc -march=i686 -mtune=generic -O2 -pipe -R/tmp/yaourt-tmp-dixie/aur-ruby-xapian-full/pkg/usr/lib/ruby/gems/1.9.1/gems/xapian-full-1.2.3/lib conftest.c >&5
gcc: error: unrecognized option '-R'
configure:3892: $? = 1
configure:3930: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "xapian-core"
| #define PACKAGE_TARNAME "xapian-core"
| #define PACKAGE_VERSION "1.2.3"
| #define PACKAGE_STRING "xapian-core 1.2.3"
| #define PACKAGE_BUGREPORT "http://xapian.org/bugs"
| #define PACKAGE_URL ""
| #define PACKAGE "xapian-core"
| #define VERSION "1.2.3"
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:3935: error: in `/tmp/yaourt-tmp-dixie/aur-ruby-xapian-full/pkg/usr/lib/ruby/gems/1.9.1/gems/xapian-full-1.2.3/xapian-core-1.2.3':
configure:3939: error: C compiler cannot create executables
See `config.log' for more details.

cgirard commented on 2011-04-05 15:02

I got the following error during libgetopt.la compilation:
libtool: link: `common/getopt.lo' is not a valid libtool object