Package Details: ruby2.2 2.2.8-1

Git Clone URL: https://aur.archlinux.org/ruby2.2.git (read-only)
Package Base: ruby2.2
Description: An object-oriented language for quick and easy programming
Upstream URL: http://www.ruby-lang.org/en/
Licenses: custom, BSD
Submitter: jhass
Maintainer: jhass
Last Packager: jhass
Votes: 9
Popularity: 0.359329
First Submitted: 2016-01-01 23:36
Last Updated: 2017-09-14 17:56

Latest Comments

felixonmars commented on 2017-06-02 12:52

Another fix is needed for GCC 7:

https://bugs.ruby-lang.org/issues/13150

felixonmars commented on 2017-05-15 15:06

It doesn't build with openssl 1.1 in [core]:

compiling init.c
compiling readline.c
compiling _sdbm.c
compiling ripper.c
linking shared-object sdbm.so
linking shared-object readline.so
In file included from ossl.h:58:0,
from ossl_pkey_rsa.c:13:
/usr/include/openssl/asn1_mac.h:10:2: error: #error "This file is obsolete; please update your software."
#error "This file is obsolete; please update your software."
^~~~~
In file included from ossl.h:58:0,
from ossl_rand.c:11:
/usr/include/openssl/asn1_mac.h:10:2: error: #error "This file is obsolete; please update your software."
#error "This file is obsolete; please update your software."
^~~~~