Package Details: rubymine 2017.2.3-1

Git Clone URL: https://aur.archlinux.org/rubymine.git (read-only)
Package Base: rubymine
Description: Ruby and Rails IDE with the full stack of essential developer tools.
Upstream URL: https://www.jetbrains.com/ruby/
Licenses: custom
Submitter: None
Maintainer: supermario
Last Packager: supermario
Votes: 93
Popularity: 1.222196
First Submitted: 2011-04-06 08:10
Last Updated: 2017-09-08 11:14

Latest Comments

bergalath commented on 2016-12-01 08:51

@supermario New release available :

pkgver=2016.3
sha256=354915f2a4748558efb4f5bc48cc1cafc38b442f198fdb7098b347df3792fbff

And I also confirm the java-environment dependency can be removed !

Thanks for maintaining this package ;)

njam commented on 2016-11-21 20:17

Yes, java dependency can be removed. Tested + works fine without.

amenzhinsky commented on 2016-06-30 08:14

Could you remove java dependencies from PKGBUILD, since custom jre build is already included in the intallation

Rhinoceros commented on 2016-05-25 12:35

@supermario Yes, I agree. Using the epoch seems wrong, and you'll have to increment it every time upstream pushes weird versions. I'm not really sure how PKGBUILD versions are sorted, but perhaps you might be able to use a modified version, like `2016.1.1_b` (if that is even larger than `2016.1.1`)? Perhaps ask on the Arch forums? Also, thank you for the build fix, it works fine now.

supermario commented on 2016-05-25 11:55

@crotok should be fixed now

@Rhinoceros I'm not sure how to get the pkgver to sort ahead as that is what upstream has named their version... I suppose it is possible to increment the epoch, but that seems kind of hacky...

Rhinoceros commented on 2016-05-25 02:20

I have the same problem as @crotok. Further, the pkgver of `2016.1.1b` is sorted before `2016.1.1`, so I never even saw this update, according to both pacaur and packer.

crotok commented on 2016-05-25 01:59

I had issue installing the last rubymine version 2016.1.1b.
It fails line 28 of the PKGBUILD file. The archive is extracted in the folder "RubyMine-2016.1.1" not "RubyMine-2016.1.1b".

zerophase commented on 2016-04-05 00:43

@supermario I got it working. The issue was installing rake from the quarry repo didn't place rake in /usr/lib/ruby/gems/2.3.0/gems/rake-11.1.2/bin/rake. I just uninstalled from quarry, installed rake with gem, and then ruby-debug-ide.

supermario commented on 2016-04-04 23:14

@zerophase can you please describe when this is happening or provide a screenshot? It is working fine for me, so I'm not sure what might be happening.

zerophase commented on 2016-04-04 01:52

RubyMine keeps asking me to install Ruby-debug-ide. How am I supposed to install ruby-debug-ide? I keep getting errors when trying to install it.

All comments