Package Details: rustdesk-git 1.2.5.r9318.g74c24ca-1

Git Clone URL: https://aur.archlinux.org/rustdesk-git.git (read-only, click to copy)
Package Base: rustdesk-git
Description: Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!
Upstream URL: https://rustdesk.com/
Keywords: desktop remote rustdesk
Licenses: AGPL-3.0-only
Conflicts: rustdesk
Provides: rustdesk
Submitter: taotieren
Maintainer: taotieren (Ataraxy, severach, mgrep1977)
Last Packager: severach
Votes: 7
Popularity: 0.63
First Submitted: 2021-06-27 07:30 (UTC)
Last Updated: 2024-05-29 16:19 (UTC)

Required by (2)

Sources (8)

Latest Comments

1 2 3 4 Next › Last »

zzy-ac commented on 2024-05-28 11:18 (UTC) (edited on 2024-05-28 11:18 (UTC) by zzy-ac)

==> Starting prepare()...
==> _dpr_check
==> _prepare_vc
  -> Copy /opt/vcpkg
cp: cannot stat '/opt/vcpkg': No such file or directory
/usr/share/makepkg/util/message.sh: line 84: RED: unbound variable
/usr/sbin/makepkg: line 131: logpipe: unbound variable
 -> error making: rustdesk-git-exit status 1
 -> Failed to install the following packages. Manual intervention is required:
rustdesk-git - exit status 1

vcpkg changed path

mgrep1977 commented on 2024-05-15 12:33 (UTC) (edited on 2024-05-15 12:42 (UTC) by mgrep1977)

"flutter pub upgrade" Results in the following error:

Resolving dependencies... (9.8s)
Note: intl is pinned to version 0.19.0 by flutter_localizations from the flutter SDK.
See https://dart.dev/go/sdk-version-pinning for details.


Because every version of dash_chat_2 from git depends on intl ^0.18.0 and every version of flutter_localizations from
  sdk depends on intl 0.19.0, dash_chat_2 from git is incompatible with flutter_localizations from sdk.
So, because flutter_hbb depends on both flutter_localizations from sdk and dash_chat_2 from git, version solving failed.




Because flutter_hbb depends on flutter_localizations from sdk which doesn't exist (the Flutter SDK is not available),
  version solving failed.

mgrep1977 commented on 2024-05-10 10:07 (UTC) (edited on 2024-05-15 12:41 (UTC) by mgrep1977)

This time it is not able to compile pam-sys, when there the following error occures and the building stops:

error[E0412]: cannot find type `__builtin_va_list` in this scope
   --> /home/maikelg/.cache/yay/rustdesk-git/src/rustdesk/target/release/build/pam-sys-715f16a7afc9951c/out/bindings.rs:277:27
    |
277 | pub type __gnuc_va_list = __builtin_va_list;
    |                           ^^^^^^^^^^^^^^^^^ not found in this scope

For more information about this error, try `rustc --explain E0412`.
error: could not compile `pam-sys` (lib) due to 1 previous error
warning: build failed, waiting for other jobs to finish...
++ error_function build
++ ((  ! BASH_SUBSHELL  ))
+++ gettext 'A failure occurred in %s().'
++ error 'A failure occurred in %s().' build
++ local 'mesg=A failure occurred in %s().'
++ shift
+++ gettext ERROR:
++ printf '==> ERROR: A failure occurred in %s().\n' build
==> ERROR: A failure occurred in build().
+++ gettext Aborting...
++ plainerr Aborting...
++ plain Aborting...
++ ((  QUIET  ))
/usr/share/makepkg/util/message.sh: line 51: QUIET: unbound variable
+++ clean_up
+++ local EXIT_CODE=1
+++ ((  INFAKEROOT  ))
/usr/bin/makepkg: line 131: logpipe: unbound variable
 -> error making: rustdesk-git-exit status 1
 -> Failed to install the following packages. Manual intervention is required:
rustdesk-git - exit status 1

mgrep1977 commented on 2024-04-27 07:59 (UTC)

Can you update PKGBUILD to include flutter 3.19.6? The requirement changed once again.

mgrep1977 commented on 2024-04-07 10:40 (UTC) (edited on 2024-04-07 15:41 (UTC) by mgrep1977)

As it is not possible for me to push a commit I will ask here. Can you update PKGBUILD to include flutter 3.19.5 as in my case the builds with flutter 3.16.9 do not work. Upgraded it myself in the PKGBUILD to 3.19.5 and the builds are working again but it would be great if this change is already included in the package, thanks in advance please. I saw this behaviour for the first time in the following release: 1.2.4.r231.g41d99d510-1 After making the changes in the PKGBUILD and issuing makepkg the build release shows the following version: rustdesk-git 1.2.4.r0.g65f7541ec-1

Bad-Mad commented on 2024-02-13 09:15 (UTC)

Is it possible to change the flutter version to 3.16.9 in the "PKGBUILD"? (_FLUVER='3.16.9') With the older version makepkg aborts.

Flammkuchen commented on 2023-09-04 23:06 (UTC)

rustdesk is now at version 1.2.3. You should update the package as at the moment it is not buildable (pkgver() fails).

gcc and make are part of base-devel and should not be used in the makedepends array https://wiki.archlinux.org/title/PKGBUILD#makedepends

Flammkuchen commented on 2023-07-31 13:24 (UTC)

I'm sorry, I forgot that I added the epoch locally. While I'm not a fan of your solution it works and there won't be an epoch.

severach commented on 2023-07-31 04:01 (UTC)

I did not add or remove the epoch. I added a fake version so upgrades work properly until the next version.

Flammkuchen commented on 2023-07-30 17:56 (UTC)

Please add the epoch back. Once there is an epoch, it has to stay and can't go down.