Package Details: rxvt-unicode-patched 9.22-11

Git Clone URL: https://aur.archlinux.org/rxvt-unicode-patched.git (read-only, click to copy)
Package Base: rxvt-unicode-patched
Description: Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing
Upstream URL: http://software.schmorp.de/pkg/rxvt-unicode.html
Licenses: GPL
Conflicts: rxvt-unicode
Provides: rxvt-unicode
Submitter: thestinger
Maintainer: blueyed
Last Packager: blueyed
Votes: 254
Popularity: 0.86
First Submitted: 2010-12-21 01:39
Last Updated: 2019-06-14 11:17

Required by (31)

Sources (8)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

hybrid commented on 2016-06-06 14:00

encountered the same error dummys reported.
Rebuilding rxvt-unicode-patched fixed it for me.

dummys commented on 2016-06-06 08:38

After upgrading to latest arch package I get a: [ 116.135112] urxvtd[1376]: segfault at 10 ip 00007fbe58ec7689 sp 00007fffed4e6220 error 4 in libperl.so[7fbe58db0000+1e8000]
when trying to connect to the deamon with rxvt.

-> $ urxvtd
rxvt-unicode daemon listening on
./rxvtperl.c: loadable library and perl binaries are mismatched (got handshake key 0xdb00080, needed 0xdb80080)
[1] 6928 segmentation fault (core dumped) urxvtd

I think the lib that cause that is: [2016-06-06 10:15] [ALPM] upgraded perl (5.22.2-1 -> 5.24.0-1)

The-Compiler commented on 2016-05-17 06:46

Oooh, indeed I did! Sorry, didn't notice. Fixed. :)

Distorted commented on 2016-05-15 20:16

I mean, did you forget to change the .SRCINFO file, because the aur still says version 9.22-3, but you changed it to 9.22-4 in the PKGBUILD but not in the .SRCINFO.

The-Compiler commented on 2016-05-13 18:46

no - I kept the patch in the sources (as I hope to re-enable it soon-ish?), I just disabled the actual patching.

Distorted commented on 2016-05-13 18:29

did you forget to update .SRCINFO?

Distorted commented on 2016-05-13 08:48

@blueyed
I hadded the options yes.

After some trying i noticed two things. It stopped crashing when i commented out the font.
which is URxvt.font:xft:DejaVu Sans Mono for Powerline:style=Book:pixelsize=15

It also stop crashing if i removed my vim config, i use airline, which also uses powerline fonts.

blueyed commented on 2016-05-11 23:07

Ouch, sorry for the trouble!

@juantascon
> latest patch is failing on me when I try to print weird characters, (ex: '\0')

Just with `printf '\0'`?
What font are you using?

@Distorted
1. What font are you using?
2. Does it happen always, regardless of the size of the window, the file being opened etc?
3. You had to added "options=('debug' '!strip')" to the PKGBUILD, have you?

I am using this font:

% xrdb -q|grep -i rxvt.font:
URxvt.font: xft:UbuntuMonoDerivativePowerline Nerd Font:size=8,xft:DejaVu Sans Mono,xft:monospace,xft:Symbola

The-Compiler commented on 2016-05-11 22:08

I pushed a quick update to disable the patch for now until those issues are sorted out.

juantascon commented on 2016-05-11 21:42

latest patch is failing on me when I try to print weird characters, (ex: '\0')
is there a font that's needed or something?