Package Details: rxvt-unicode-truecolor 9.31-1

Git Clone URL: https://aur.archlinux.org/rxvt-unicode-truecolor.git (read-only, click to copy)
Package Base: rxvt-unicode-truecolor
Description: Unicode enabled rxvt-clone terminal emulator (urxvt) with true color patch (24bit colors support). That enables vim 24-bit true color colorshemes
Upstream URL: http://software.schmorp.de/pkg/rxvt-unicode.html
Licenses: GPL
Conflicts: rxvt-unicode
Provides: rxvt-unicode
Submitter: sergt
Maintainer: Rosy
Last Packager: Rosy
Votes: 7
Popularity: 0.000004
First Submitted: 2019-01-20 15:53 (UTC)
Last Updated: 2023-09-14 07:56 (UTC)

Required by (27)

Sources (5)

Latest Comments

Nexrem commented on 2023-09-13 20:14 (UTC)

This currently fails to build due to a change in ncurses leading to this error

"./etc/rxvt-unicode.terminfo", line 7, terminal 'rxvt-unicode': /usr/share/terminfo/r: permission denied

This is because of a breaking change in ncurses. See here https://bugs.archlinux.org/task/79143?project=1&openedfrom=-1+week.

To fix this issue as of now you can rebuild ncurses with the flag described in the link above removed (makepkg -s) and then reinstall it inplace with pacman -U. Do not at any point remove ncurses with -Rdd because the whole system depends on this.

The package maintainer of this package should update it accordingly to work with latest ncurses changes. I've marked it as outdated for now.

bananabrain commented on 2023-02-06 13:57 (UTC)

Is there something wrong with Squiffy's comment? It still applies five months later.

libtytty is a dependency for the community build...

https://archlinux.org/packages/community/x86_64/rxvt-unicode/

rxvt-unicode appears to be the only package that depends on it.

Squiffy commented on 2022-08-27 12:03 (UTC)

This is missing a dependency on libtytty

$ urxvt
urxvt: error while loading shared libraries: libptytty.so.0: cannot open shared object file: No such file or directory

jsamr commented on 2020-03-26 15:10 (UTC) (edited on 2020-03-26 15:11 (UTC) by jsamr)

@sergt Hi!

Could you add the font-patch which fixes the endemic font spacing bug in urxvt? That would be fantastic!

https://aur.archlinux.org/cgit/aur.git/tree/font-width-fix.patch?h=rxvt-unicode-patched
https://aur.archlinux.org/cgit/aur.git/tree/fix-smart-resize-with-x11-frame-borders.patch?h=rxvt-unicode-patched

emceeMC commented on 2020-03-01 20:25 (UTC)

I know this is a silly question for here, but how would I install this patch on Debian i3?

sergt commented on 2020-02-20 22:06 (UTC)

Updated. If somebody know, send me message with new location of the patch.

sysrob commented on 2020-02-11 11:05 (UTC) (edited on 2020-02-11 11:07 (UTC) by sysrob)

The actual patch URL is broken:

https://gist.githubusercontent.com/dan-santana/63271adf12171e0fc0bc/raw/70c6343d1c0b3bca0aba4f587ed501e6cbd98d00/24-bit-color.patch

is this other location also valid?

https://gist.githubusercontent.com/cpixl/63271adf12171e0fc0bc/raw/70c6343d1c0b3bca0aba4f587ed501e6cbd98d00/24-bit-color.patch

JasonP commented on 2019-06-11 16:37 (UTC) (edited on 2019-06-11 19:48 (UTC) by JasonP)

After daily system upgrade rxvt-unicode doesn't start:

error while loading shared libraries: libperl.so

rxvt-unicode-terminfo was updated to 9.22-9

perl was updated to 5.30.0-2

Problem solved rebuilding package