Package Details: ryzom-server-git r9767.a6139ade2-1

Git Clone URL: https://aur.archlinux.org/ryzom-git.git (read-only, click to copy)
Package Base: ryzom-git
Description: Ryzom is a Free to Play MMORPG . This is the version to run a server
Upstream URL: http://www.ryzom.com/
Licenses: AGPL3
Conflicts: ryzom-client-latest-hg
Provides: ryzom
Submitter: LinuxDonald
Maintainer: LinuxDonald
Last Packager: LinuxDonald
Votes: 1
Popularity: 0.000000
First Submitted: 2020-09-26 16:07 (UTC)
Last Updated: 2022-03-05 12:50 (UTC)

Latest Comments

1 2 3 4 5 6 7 Next › Last »

LinuxDonald commented on 2022-03-05 22:11 (UTC)

Lzma problem is now fixed in git.

LinuxDonald commented on 2022-03-05 15:10 (UTC)

Created an bug report for it: https://github.com/ryzom/ryzomcore/issues/663

LinuxDonald commented on 2022-03-05 12:51 (UTC) (edited on 2022-03-05 12:56 (UTC) by LinuxDonald)

I have uploaded an new pkgbuild. But still problem with lzma conflict. I talking with devs to get this resolved.

Easy way would be delete lzma from ryzom package. But first i want to try an better/clean way.

LinuxDonald commented on 2022-03-05 11:15 (UTC)

I have fixed up the luabind package. I´m on the ryzom package.

silversilva commented on 2022-02-06 12:18 (UTC) (edited on 2022-02-06 12:30 (UTC) by silversilva)

I tried installing this package.

I was able to install luabind-ryzom-git with this PKGBUILD file - https://gist.github.com/rebinsilva/ff6dbf052c088f9fb58b4f3473d1ff3d (Sorry, I don't know bjam. So i used cmake to build and install).

I was able to build ryzom-client-git with this PKGBUILD file - https://gist.github.com/rebinsilva/3b4be589b2cec9e7df8dd2d02b1d5565 . But during installation, it tried to create /usr/bin/lzma which was already created and owned by xz and hence failed.

LinuxDonald commented on 2022-02-01 14:59 (UTC)

Im still on this package. I created an new luabind packages that is forked by the ryzom team. I hope i can try to build it on this weekend and fix up the pkgbuild file.

LinuxDonald commented on 2021-12-05 12:37 (UTC)

I will fix this package. But i cant do it now. I dont have yet Arch based distro running. I will fix this in the next two months. They have do lot changes upstream. Lua dep is fixed there to.

janilowski commented on 2021-12-05 12:10 (UTC) (edited on 2021-12-05 12:11 (UTC) by janilowski)

Okay, this package is broken and either needs to be updated or deleted. I've had a trillion issues with this and still couldn't install it. I gave up when this message popped up: ==> ERROR: pkgver is not allowed to contain colons, forward slashes, hyphens or whitespace. ==> ERROR: pkgver() generated an invalid version: ryzom/3.5.0.9637.r1199.ga087eacc2

Here are some things that might help you, if you're trying to install this anyway: 1. Install lua51 from extra (sudo pacman -S lua51) 2. You will get errors when installing luabind-rpavlik-git (which is a dependency) so install it independently from the AUR by adding these two lines to the build function in it's PKGBUILD: export BOOST_BUILD_PATH=/usr/share/boost-build/src/kernel/ export LUA_PATH=/usr/include/lua5.1 3. 99% you will get errors when installing other dependencies so you should install them independently and work out the errors manually. 4. Cry and get frustrated, because at the end, you will probably run into the same 'version' problem as I did :P

LinuxDonald commented on 2020-09-26 21:23 (UTC)

Done

caltlgin commented on 2020-09-26 17:19 (UTC)