Package Details: s3ql 2.28-1

Git Clone URL: https://aur.archlinux.org/s3ql.git (read-only)
Package Base: s3ql
Description: A full-featured file system for online data storage.
Upstream URL: https://bitbucket.org/nikratio/s3ql/overview
Licenses: GPL3
Submitter: bremac
Maintainer: None
Last Packager: tilal6991
Votes: 9
Popularity: 0.080556
First Submitted: 2010-12-28 01:15
Last Updated: 2018-07-04 19:55

Latest Comments

1 2 3 Next › Last »

dugenou commented on 2018-10-10 19:31

I'm struggling with s3qpl with the following message when using mkfs.s3ql: not sure which missing crypto package, as I installed all of them (python-crypto related).

mkfs.s3ql s3://myfsdocs --ssl Traceback (most recent call last): File "/usr/bin/mkfs.s3ql", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 3112, in <module> @_call_aside File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 3096, in _call_aside f(args, *kwargs) File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 3125, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 578, in _build_master ws.require(requires) File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 895, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.7/site-packages/pkg_resources/init.py", line 781, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'pycrypto' distribution was not found and is required by s3ql</module></module>

IsaacG commented on 2018-08-16 05:50

The source contains a src/s3ql/deltadump.c generated from a src/s3ql/deltadump.pyx

The .pyx is part of the S3QL codebase. The .c is auto-generated using Cython 0.25.2; it's probably included over being built with makepkg to avoid the Cython dependency.

Python 3.7 made changes which broke Cython prior to 0.28 (or <=0.27.2 or something). The generated 0.25.2 code definitely doesn't work anymore with Python3.7. As such, that source file with the generated Cython 0.25.2 file are not compatible with Python 3.7 and this package is "broken".

The fix would be to run: cython src/s3ql/deltadump.pyx (or cython src/s3ql-2.28/src/s3ql/deltadump.pyx, followed by makepkg -ef).

wilbowma commented on 2017-01-07 18:41

Also seems to require a patched version of python-defusedxml to work with 3.6, https://github.com/tiran/defusedxml/issues/3

I've made a package for the patched version here: https://aur.archlinux.org/packages/python-defusedxml-git/

wilbowma commented on 2017-01-07 18:27

Looks like dependencies are out of date. dugong >= 3.4 < 4, python-llfuse >= 1 < 2

http://www.rath.org/s3ql-docs/installation.html

bremac commented on 2016-04-03 07:24

Sorry, I held off upgrading to 2.17.1 (which is compatible with llfuse 1.0) to see if any more serious bugs appeared in this release. Since there haven't been any new reports in the last week or so, I've gone ahead and made the change. Let me know if you have any other problems.

wilbowma commented on 2016-04-03 05:06

I just upgraded, and now I get "pkg_resources.DistributionNotFound: The 'llfuse<1.0,>=0.43' distribution was not found and is required by s3ql".
python-llfuse 1.0 is in the repos, but s3ql requires < 1.0

bremac commented on 2014-03-29 18:39

I've released 2.8. Let me know if there are any issues -- there was some sort of issue with llfuse not being registered properly with pkg_resources, so I forced an update by requiring llfues >= 0.40-2. Hopefully this fixes the problem.

bremac commented on 2013-08-10 22:29

Sorry, I didn't have any time last weekend. 2.3 seems to be stable now (in that I can actually build the package and use it), and the real changes are in the implementation instead of the interface, so I have no problem with upgrading to 2.x.

Please be sure to unmount your s3ql filesystems before upgrading from 1.x to 2.x.

yar commented on 2013-08-10 01:53

Any chance of getting the 2.x branch, or should that be a separate package? Either way you're still out-of-date...

bremac commented on 2013-04-26 00:23

Thanks, I've updated the dependency.